summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-01-18 12:35:19 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-01-18 12:35:19 +0100
commit2cbded7a0360bf8e5cbd89f3fec827c9040bbc7d (patch)
tree10b15d2823bd01b3f437100718445ccbc9adeb13 /dev-ml/ocamlnet
parentapp-admin/cdist: fix test (diff)
downloadgentoo-2cbded7a0360bf8e5cbd89f3fec827c9040bbc7d.tar.gz
gentoo-2cbded7a0360bf8e5cbd89f3fec827c9040bbc7d.tar.bz2
gentoo-2cbded7a0360bf8e5cbd89f3fec827c9040bbc7d.zip
dev-ml/ocamlnet: use toolchain-funcs eclass to get cpp
Closes: https://bugs.gentoo.org/751274 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild5
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild5
2 files changed, 6 insertions, 4 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
index 8976098b07bc..135e3afb853c 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.8-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit findlib
+inherit findlib toolchain-funcs
MY_P=${P/_beta/test}
DESCRIPTION="Modules for OCaml application-level Internet protocols"
@@ -61,6 +61,7 @@ src_configure() {
$(ocamlnet_use_enable tk tcl) \
$(ocamlnet_use_enable zip zip) \
$(ocamlnet_use_with httpd nethttpd) \
+ -cpp $(tc-getPROG CPP cpp) \
|| die "Error: econf failed!"
}
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
index 8976098b07bc..135e3afb853c 100644
--- a/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit findlib
+inherit findlib toolchain-funcs
MY_P=${P/_beta/test}
DESCRIPTION="Modules for OCaml application-level Internet protocols"
@@ -61,6 +61,7 @@ src_configure() {
$(ocamlnet_use_enable tk tcl) \
$(ocamlnet_use_enable zip zip) \
$(ocamlnet_use_with httpd nethttpd) \
+ -cpp $(tc-getPROG CPP cpp) \
|| die "Error: econf failed!"
}