summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-23 14:25:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-23 17:11:25 +0200
commit7a70cae414026d267d84b41cfb995d996bf565b4 (patch)
tree3b7664844595d8edd7482a159d79acf721a887b9 /dev-ml
parentdev-ml/ocaml-ctypes: bump to 0.9.0 (diff)
downloadgentoo-7a70cae414026d267d84b41cfb995d996bf565b4.tar.gz
gentoo-7a70cae414026d267d84b41cfb995d996bf565b4.tar.bz2
gentoo-7a70cae414026d267d84b41cfb995d996bf565b4.zip
dev-ml/ocaml-containers: bump to 0.19
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index 3b998aa80135..b426f01dc848 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1 +1,2 @@
DIST ocaml-containers-0.18.tar.gz 418480 SHA256 8bac90113e229a9dc55a2f54c20cf363df43c2e72ca349a5a811ad113a6d2909 SHA512 fa61039fc3bbfcd53117ae582689ffca645b42a811ebe0fc8aa5da93ba5373c2ac54896ecaddbe3eff7593b2be44f208abb625ad3354d2b089a0b811b9f77cff WHIRLPOOL 10795e812baab4525f6fdfbc101c7b14230ef87893ccf01702a6a75e373a12bf643f775f63cb27640f0dd398da541e6c185489dc27cd9fc7bd75a4a90f34baf2
+DIST ocaml-containers-0.19.tar.gz 419243 SHA256 e53472e009ea2699f39940844fc0ef9abb332234834c6963f8325aa7df0694f5 SHA512 1ed078121770d72ba685c116ddeebc848b086e371604c7fedf1bdb58ea5cb9685db8a3c7c4edcac69a9cd18ece1eb601d1675c25efe6ab61e2a511a8a857aff2 WHIRLPOOL 27df23c2b0196647f071089d2044dbb7cf4b2c710bdc066eda892e8e4ffe229d5bafc2ec29b5afc4cffd0513d69d16776342258e667e62613ff2c771762ea1d5
diff --git a/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild b/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild
new file mode 100644
index 000000000000..9b88e573f8e9
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-0.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/sequence:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo"
+PATCHES=( "${FILESDIR}/notests.patch" )
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}