summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-10 03:33:53 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-10 03:35:01 +1200
commit59a04a481c15788a6798996b271efabbbcc78a03 (patch)
treeb56930c91c71635bed84d3aa0436596a4b888e6c /dev-perl/Boulder/files
parentRevert "app-emulation/qemu: conditionally depend on python" (diff)
downloadgentoo-59a04a481c15788a6798996b271efabbbcc78a03.tar.gz
gentoo-59a04a481c15788a6798996b271efabbbcc78a03.tar.bz2
gentoo-59a04a481c15788a6798996b271efabbbcc78a03.zip
dev-perl/Boulder: Bulk fixes and fix for bug #678004
- Convert to EAPI6 - Omit Boulder::Store support unless USE=store is specified, as Boulder::Store requires DB_File, which requires perl built with USE="berkdb", and triggering a perl rebuild flipping a use flag could really complicate portage's capacity to solve dependencies, and possibly break your perl. (This is exposed bug bug #678004) - Omit Boulder::Labbase as the module is incomplete, is documented as such, and loads dependencies that aren't available on Gentoo or on CPAN. - Omit Boulder::XML and its dependency on XML-Parser unless USE=xml is specified, as XML handling is not in any way critical to this module. - Remove uncondtional compile-time assertion for XML::Parser - Omit Boulder::Genbank and related assets unless USE=genbank is specified, as this necesarily adds a dependency on dev-perl/CGI as part of its Entrez accessor - Provide examples via USE="examples" Closes: https://bugs.gentoo.org/678004 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Boulder/files')
-rw-r--r--dev-perl/Boulder/files/Boulder-1.30-no-xml-parser-check.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Boulder/files/Boulder-1.30-no-xml-parser-check.patch b/dev-perl/Boulder/files/Boulder-1.30-no-xml-parser-check.patch
new file mode 100644
index 000000000000..13ce87969fb1
--- /dev/null
+++ b/dev-perl/Boulder/files/Boulder-1.30-no-xml-parser-check.patch
@@ -0,0 +1,30 @@
+From 82eaa751a4aebb6cce70b83407c1fafd13334130 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 10 Jul 2019 02:58:13 +1200
+Subject: Remove hardcoded XML::Parser check
+
+This test isn't necessary and is a vestigal side effect of old build
+chains that didn't have prereqs.
+
+As this dependency is only needed if you're using Boulder::XML, its
+rather redundant.
+---
+ Makefile.PL | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index 2fe3176..245f16e 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,8 +1,5 @@
+ use ExtUtils::MakeMaker;
+
+-eval "use XML::Parser; 1"
+- || warn "XML::Parser module not found. This module is required to use Boulder::XML\n";
+-
+ WriteMakefile(
+ 'NAME' => 'Boulder',
+ 'DISTNAME' => 'Boulder',
+--
+2.22.0
+