summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Class-Load
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Class-Load')
-rw-r--r--dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild32
-rw-r--r--dev-perl/Class-Load/Class-Load-0.220.0.ebuild39
-rw-r--r--dev-perl/Class-Load/Class-Load-0.230.0.ebuild38
-rw-r--r--dev-perl/Class-Load/Manifest3
-rw-r--r--dev-perl/Class-Load/metadata.xml10
5 files changed, 122 insertions, 0 deletions
diff --git a/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild b/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
new file mode 100644
index 000000000000..3cf847729b7b
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.200.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DROLSKY
+MODULE_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Data-OptList
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Package-Stash-0.320.0
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Fatal
+ dev-perl/Test-Requires
+ )"
+
+SRC_TEST="do"
diff --git a/dev-perl/Class-Load/Class-Load-0.220.0.ebuild b/dev-perl/Class-Load/Class-Load-0.220.0.ebuild
new file mode 100644
index 000000000000..7c93395047a7
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.220.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Data-OptList
+ virtual/perl-Exporter
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Package-Stash-0.140.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+ dev-perl/namespace-clean
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ >=dev-perl/Module-Build-Tiny-0.37.0
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ virtual/perl-Test-Simple
+ dev-perl/Test-Requires
+ )
+"
+
+SRC_TEST="do"
diff --git a/dev-perl/Class-Load/Class-Load-0.230.0.ebuild b/dev-perl/Class-Load/Class-Load-0.230.0.ebuild
new file mode 100644
index 000000000000..89e9112bd7d1
--- /dev/null
+++ b/dev-perl/Class-Load/Class-Load-0.230.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=0.23
+inherit perl-module
+
+DESCRIPTION="A working (require q{Class::Name}) and more"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="test"
+
+# uses Scalar-Util
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Data-OptList
+ virtual/perl-Exporter
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Package-Stash-0.140.0
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Try-Tiny
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ dev-perl/Test-Requires
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Class-Load/Manifest b/dev-perl/Class-Load/Manifest
new file mode 100644
index 000000000000..0df0d6bc37d6
--- /dev/null
+++ b/dev-perl/Class-Load/Manifest
@@ -0,0 +1,3 @@
+DIST Class-Load-0.20.tar.gz 20271 SHA256 823c45885e1d29feef6867282b881d402f42af6413c7e0e9f8fe32086aee8c20 SHA512 e208a3c6fc01b8ad33dbdac29eb9d11914686822bb607fbdf0eaeb6ea375a8c77bd85e85b6eaced2aff1c8f0424033b428a42a1f2b2c4fb4eeefe38a8d0abe48 WHIRLPOOL e581dd81b21e145ea5bd1cb4d2962103cfb751fb11bd9f7ad120d0aa39da0cd4164bf002c29be45b6dc97de366f4a935498505b686f1386c4f0058f78ae390d0
+DIST Class-Load-0.22.tar.gz 34179 SHA256 be52db6081b565002d68a1578ed06c7777b8845e92597be47f1c22e90b123111 SHA512 1f61c9ffd0c7d854c830143109f0b0f98a3f9666971d3f0b2567fd97f7aa703bf0bc9f7342f0489d90ac4765d90695a5783f822458e0eb9a6f5cf4c98b465da4 WHIRLPOOL 7efa52d7b50b60f1905d4341ce5aa9db9a37f3ce4d8507fd0b7e4bb50f2df47a603d7aa8080e82f04222c32b5e3058a6ffc19add4ffa73f27ac470186cf22aa9
+DIST Class-Load-0.23.tar.gz 33610 SHA256 f2bca579e72ea96c6b1c5ebc86dfa1929062c412443277f0bc0437e50874b28f SHA512 c4e39a0b53dcb9e91c6ac160b15d253aa257fc327c2f4e333b8a3689a6c697412385d47d0a52e55a9420b8cc1a7f46d8d0c1ff54f13ae2a88e0f9df8935cffed WHIRLPOOL 5c75ba558f0b507f8c756bb63fc1882c3b29546e8340b6ad2f046ab183d364ca0cdcbc09f3ce2491a2e1a852499b657f0f8bbc5cf293a523cc9443d299347c08
diff --git a/dev-perl/Class-Load/metadata.xml b/dev-perl/Class-Load/metadata.xml
new file mode 100644
index 000000000000..6dccc0a617b2
--- /dev/null
+++ b/dev-perl/Class-Load/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Class-Load</remote-id>
+ <remote-id type="cpan-module">Class::Load</remote-id>
+ <remote-id type="cpan-module">Class::Load::PP</remote-id>
+ </upstream>
+</pkgmetadata>