summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-14 12:43:09 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-15 10:56:14 -0400
commit6c1e452492ab2b24966ed998c526464c2cd58797 (patch)
treecfaf98ab9a676f3213df0f198907285b43697a32 /dev-perl/DBD-MariaDB
parentdev-perl/DateTimeX-Easy: Drop old versions (diff)
downloadgentoo-6c1e452492ab2b24966ed998c526464c2cd58797.tar.gz
gentoo-6c1e452492ab2b24966ed998c526464c2cd58797.tar.bz2
gentoo-6c1e452492ab2b24966ed998c526464c2cd58797.zip
dev-perl/DBD-MariaDB: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-perl/DBD-MariaDB')
-rw-r--r--dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0-r1.ebuild86
-rw-r--r--dev-perl/DBD-MariaDB/DBD-MariaDB-1.220.0.ebuild88
-rw-r--r--dev-perl/DBD-MariaDB/Manifest2
3 files changed, 0 insertions, 176 deletions
diff --git a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0-r1.ebuild b/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0-r1.ebuild
deleted file mode 100644
index cbdea799bc45..000000000000
--- a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.210.0-r1.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DIST_AUTHOR=PALI
-DIST_VERSION=1.21
-inherit perl-module
-
-DESCRIPTION="MariaDB and MySQL driver for the Perl5 Database Interface (DBI)"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test +mariadb mysql minimal"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="^^ ( mysql mariadb )"
-
-RDEPEND="
- >=dev-perl/DBI-1.608.0
- virtual/perl-XSLoader
- mysql? ( dev-db/mysql-connector-c:0= )
- mariadb? ( dev-db/mariadb-connector-c:0= )
-"
-# New test-harness needed for parallel testing to work
-DEPEND="${RDEPEND}
- virtual/perl-Data-Dumper
- >=dev-perl/Devel-CheckLib-1.120.0
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-File-Spec
- virtual/perl-Getopt-Long
- test? (
- !minimal? (
- >=dev-perl/Net-SSLeay-1.430.0
- dev-perl/Proc-ProcessTable
- virtual/perl-Storable
- )
- virtual/perl-Encode
- virtual/perl-File-Temp
- dev-perl/Test-Deep
- >=virtual/perl-Test-Harness-3.310.0
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- virtual/perl-bignum
- )
-"
-PERL_RM_FILES=(
- "t/pod.t"
- "t/manifest.t"
-)
-
-src_configure() {
- local impl
- impl=$(usex mariadb mariadb mysql)
- if use test; then
- myconf="${myconf} --testdb=test \
- --testhost=localhost \
- --testuser=test \
- --testpassword=test"
- fi
- myconf+=" --${impl}_config=${BROOT}/usr/bin/${impl}_config"
- perl-module_src_configure
-}
-
-src_compile() {
- mymake=(
- "OPTIMIZE=${CFLAGS}"
- )
- perl-module_src_compile
-}
-src_test() {
- ewarn "Comprehensive testing requires additional manual steps. For details"
- ewarn "see:"
- ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Testing"
-
- einfo
- einfo "If tests fail, you have to configure your MariaDB/MySQL instance"
- einfo "to create and grant some privileges to the test user."
- einfo "You can run the following commands at the MariaDB/MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
- sleep 5
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.220.0.ebuild b/dev-perl/DBD-MariaDB/DBD-MariaDB-1.220.0.ebuild
deleted file mode 100644
index 9dff0780c797..000000000000
--- a/dev-perl/DBD-MariaDB/DBD-MariaDB-1.220.0.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DIST_AUTHOR=PALI
-DIST_VERSION=1.22
-inherit perl-module
-
-DESCRIPTION="MariaDB and MySQL driver for the Perl5 Database Interface (DBI)"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mariadb mysql minimal"
-REQUIRED_USE="^^ ( mysql mariadb )"
-
-RDEPEND="
- >=dev-perl/DBI-1.608.0
- virtual/perl-XSLoader
- mysql? ( dev-db/mysql-connector-c:= )
- mariadb? ( dev-db/mariadb-connector-c:= )
-"
-# New test-harness needed for parallel testing to work
-DEPEND="${RDEPEND}
- virtual/perl-Data-Dumper
- >=dev-perl/Devel-CheckLib-1.120.0
- virtual/perl-ExtUtils-MakeMaker
- virtual/perl-File-Spec
- virtual/perl-Getopt-Long
- test? (
- !minimal? (
- >=dev-perl/Net-SSLeay-1.430.0
- dev-perl/Proc-ProcessTable
- virtual/perl-Storable
- )
- virtual/perl-Encode
- virtual/perl-File-Temp
- dev-perl/Test-Deep
- >=virtual/perl-Test-Harness-3.310.0
- >=virtual/perl-Test-Simple-0.900.0
- virtual/perl-Time-HiRes
- virtual/perl-bignum
- )
-"
-
-PERL_RM_FILES=(
- "t/pod.t"
- "t/manifest.t"
-)
-
-src_configure() {
- local impl=$(usex mariadb mariadb mysql)
-
- if use test; then
- myconf=(
- ${myconf}
- --testdb=test
- --testhost=localhost
- --testuser=test
- --testpassword=test
- )
- fi
-
- myconf+=( --${impl}_config="${BROOT}"/usr/bin/${impl}_config )
-
- perl-module_src_configure
-}
-
-src_test() {
- ewarn "Comprehensive testing requires additional manual steps. For details"
- ewarn "see:"
- ewarn " https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}#Testing"
-
- einfo
- einfo "If tests fail, you have to configure your MariaDB/MySQL instance"
- einfo "to create and grant some privileges to the test user."
- einfo "You can run the following commands at the MariaDB/MySQL prompt: "
- einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
- einfo "> CREATE DATABASE test;"
- einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
- einfo
-
- sleep 5
-
- # Don't be a hero and try to do EXTENDED_TESTING=1 unless you can figure
- # out why 60leaks.t fails
- perl-module_src_test
-}
diff --git a/dev-perl/DBD-MariaDB/Manifest b/dev-perl/DBD-MariaDB/Manifest
index 267d760d3a66..1ecfc28367f0 100644
--- a/dev-perl/DBD-MariaDB/Manifest
+++ b/dev-perl/DBD-MariaDB/Manifest
@@ -1,3 +1 @@
-DIST DBD-MariaDB-1.21.tar.gz 179911 BLAKE2B dac1a868d64e792dc86ab46cea1fe2578ae691b9d6713cd83971c9ba0a3e2a0d8031c7be10dc66e4269c142aec1c54859e0e285faf9a29dc3cec7e3d8ad82a0e SHA512 0378b33e9cd31ced6f2331967c7ea63a233340bb4a60ef2bbece4843b3a62624875aa1a5e61a9fa1b709ecc8d67810c6fa4fb9ccc01df341e6d94325078f360a
-DIST DBD-MariaDB-1.22.tar.gz 180783 BLAKE2B 8125c0a1ce6858e29c894ea4e11a10fc8e3776cbf016537e6d4d492773690b915dc249ddeca881fa42b229597727602209487dcdb1af03da098e38f2652d5934 SHA512 f2bd16fa609b94bd5eb538b38b122dec6a4484da062f2cc84fa6ca4a5dfc30e7ff754a00ece22a3a30297c92b4fd3f878ab0e2a581b7082cd1b9a00f33e2b2c7
DIST DBD-MariaDB-1.23.tar.gz 186522 BLAKE2B 4202146d0c73d2e3259e54085d390d9769b46f0771b3a83a05b0203f6589ffe0f189008453448d71b5f07e8419e038ad32a1ed968c8ceffd836fb9f9cad1c9f7 SHA512 2217f36606caab477b8fa931a69b53b7f706a25cf013e4b62aa1b0b48905aba24b724604b4b99e83dea08d967848119447f35ff8e6b5eb80c7fea4e8c084de16