summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-08 08:37:24 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-08 08:37:39 +1300
commit4ac5b8e8e26afcdc8efde9df04dcffd794a314c1 (patch)
tree00d5d6b4f1481f24df7466523bc46b037f0186e8 /dev-perl/DBI/DBI-1.637.0.ebuild
parentprofiles: add hardened to the new 17.0 profile for amd64 (diff)
downloadgentoo-4ac5b8e8e26afcdc8efde9df04dcffd794a314c1.tar.gz
gentoo-4ac5b8e8e26afcdc8efde9df04dcffd794a314c1.tar.bz2
gentoo-4ac5b8e8e26afcdc8efde9df04dcffd794a314c1.zip
dev-perl/DBI: Bump to version 1.637 re bug #614644
Upstream: - Fix CWE-134 where possible crashes can occur due to db errors containing a "%" - Fix extension detection for DBD::File related drivers - Fixes for dot-in-inc on 5.26 - Fix loss of error message on parent handle - Fix $_ disappearing inside callbacks - Objects now allowed as passwords without die()ing - $sth NAME_* attributes now settable from Perl - Add support for DBD::XMLSimple Bug: https://bugs.gentoo.org/614644 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/DBI/DBI-1.637.0.ebuild')
-rw-r--r--dev-perl/DBI/DBI-1.637.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/DBI/DBI-1.637.0.ebuild b/dev-perl/DBI/DBI-1.637.0.ebuild
new file mode 100644
index 000000000000..542a4df630c2
--- /dev/null
+++ b/dev-perl/DBI/DBI-1.637.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TIMB
+DIST_VERSION=1.637
+DIST_EXAMPLES=("ex/*")
+inherit perl-module eutils
+
+DESCRIPTION="Database independent interface for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/PlRPC-0.200.0
+ >=virtual/perl-Sys-Syslog-0.170.0
+ virtual/perl-File-Spec
+ !<=dev-perl/SQL-Statement-1.330.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.480.0
+ test? (
+ >=virtual/perl-Test-Simple-0.900.0
+ )
+"
+src_test() {
+ perl_rm_files t/pod-coverage.t t/pod.t
+ perl-module_src_test
+}