summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-21 16:31:32 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-21 16:31:32 +1300
commit7a4bf542a3d9e15d8c05641174aa3a5260ad6416 (patch)
tree15e136fa6a4eef36152ca3cf6d0cdccf8b852969 /dev-perl/Exception-Died
parentdev-perl/Encode-compat: EAPI6 + Test (diff)
downloadgentoo-7a4bf542a3d9e15d8c05641174aa3a5260ad6416.tar.gz
gentoo-7a4bf542a3d9e15d8c05641174aa3a5260ad6416.tar.bz2
gentoo-7a4bf542a3d9e15d8c05641174aa3a5260ad6416.zip
dev-perl/Exception-Died: EAPI6 + Tests
- EAPI6ify - Enable tests - Add missing test dependencies Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Exception-Died')
-rw-r--r--dev-perl/Exception-Died/Exception-Died-0.60.0-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-perl/Exception-Died/Exception-Died-0.60.0-r2.ebuild b/dev-perl/Exception-Died/Exception-Died-0.60.0-r2.ebuild
new file mode 100644
index 000000000000..0ac7c6d52f3d
--- /dev/null
+++ b/dev-perl/Exception-Died/Exception-Died-0.60.0-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=DEXTER
+DIST_VERSION=0.06
+DIST_EXAMPLES=( "eg/*" )
+inherit perl-module
+
+DESCRIPTION="Convert simple die into real exception object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/constant-boolean
+ >=dev-perl/Exception-Base-0.210.0"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? ( virtual/perl-parent
+ >=dev-perl/Test-Unit-Lite-0.110.0
+ >=dev-perl/Test-Assert-0.50.0
+ )"