summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-21 15:46:55 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-21 15:46:55 +1300
commitf4296657581e1a0899193e2ad5b60864c64fe92d (patch)
treeeb84468e9d8cfa71eeb5453d23ec39d1f84f5f59 /dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild
parentdev-perl/Exception-Class: Bump to version 1.430.0 (diff)
downloadgentoo-f4296657581e1a0899193e2ad5b60864c64fe92d.tar.gz
gentoo-f4296657581e1a0899193e2ad5b60864c64fe92d.tar.bz2
gentoo-f4296657581e1a0899193e2ad5b60864c64fe92d.zip
dev-perl/ExtUtils-AutoInstall: Bump to version 0.640.0
- EAPI6 - Enable tests - Migrate Makefile.PL hack to patch - Patch tests to work Upstream: - Fix tests building properly with newer ExtUtils::MakeMaker Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild')
-rw-r--r--dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild
new file mode 100644
index 000000000000..67b5ca9597f4
--- /dev/null
+++ b/dev-perl/ExtUtils-AutoInstall/ExtUtils-AutoInstall-0.640.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=INGY
+DIST_VERSION=0.64
+inherit perl-module
+
+DESCRIPTION="Automatic installation of dependencies via CPAN from within Makefile.PL"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+# TESTS BAD. Wants to write to cpan's config on the live system
+#SRC_TEST="do"
+
+RDEPEND="dev-perl/Sort-Versions"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-dot-inc.patch"
+ "${FILESDIR}/${P}-cpantest.patch"
+)
+src_compile() {
+ echo "n" | perl-module_src_compile
+}
+
+src_test() {
+ local MODULES=(
+ "ExtUtils::AutoInstall ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ perl-module_src_test
+}