summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-21 09:00:55 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-21 09:00:55 +1200
commit4fefa82528a8e3d4202acf8025b135bbce802f53 (patch)
tree8aeeebe86bd8e16e59ad4876ee6c6ae97bd6db07 /dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild
parentdev-perl/HTML-Tree: Bump to version 5.60.0 (diff)
downloadgentoo-4fefa82528a8e3d4202acf8025b135bbce802f53.tar.gz
gentoo-4fefa82528a8e3d4202acf8025b135bbce802f53.tar.bz2
gentoo-4fefa82528a8e3d4202acf8025b135bbce802f53.zip
dev-perl/IPC-Run: Bump to verison 0.960.0 re bug #614806
- EAPI6 Upstream: - Don't waste memory importing POSIX - Allow OS to choose port - Timer now accepts all allowable perl numbers - Catch malformed time strings - Improved timer error messages - Use Win32API::File on windows - Close CHILD_HANDLE to prevent warning - Avoid side effects of flushing STDOUT/STDERR - Unify $VERSION values - Fix quotation problems with cmd.exe - Fix check for reaped PID - Remove unneeded use of UNIVERSAL - Fix test failure due to '.' in @INC removal Bug: https://bugs.gentoo.org/614806 Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild')
-rw-r--r--dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild b/dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild
new file mode 100644
index 000000000000..67a09455c012
--- /dev/null
+++ b/dev-perl/IPC-Run/IPC-Run-0.960.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=TODDR
+DIST_VERSION=0.96
+inherit perl-module
+
+DESCRIPTION="system() and background procs w/ piping, redirs, ptys"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/IO-Tty-1.80.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.470.0
+ )
+"
+
+src_test() {
+ perl_rm_files t/97_meta.t t/98_pod_coverage.t t/98_pod.t t/99_perl_minimum_version.t
+ perl-module_src_test
+}