summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Net-OAuth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Net-OAuth')
-rw-r--r--dev-perl/Net-OAuth/Manifest1
-rw-r--r--dev-perl/Net-OAuth/Net-OAuth-0.280.0-r1.ebuild33
-rw-r--r--dev-perl/Net-OAuth/metadata.xml32
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-perl/Net-OAuth/Manifest b/dev-perl/Net-OAuth/Manifest
new file mode 100644
index 000000000000..e38eb0712704
--- /dev/null
+++ b/dev-perl/Net-OAuth/Manifest
@@ -0,0 +1 @@
+DIST Net-OAuth-0.28.tar.gz 29063 SHA256 7bfc319da0ac578e00962f35a350cf51110a3a313016d1fdc30722028a22904c SHA512 b38c3784221bdf56b5b55021cc7e74cf6c5ce47b6743b6fefae9e148ff61d3c1e068aa5829dfed13ffd070e1286ab0d743e2f7b7c900f5fd8cf78f788cff70c4 WHIRLPOOL e0be6c1050bf9e44e696055fd58e5abb9aa8a0af65068dc0e42c3c263da21e4c0f3723edca3ac9a5b2ce13bcdcd403dc514ebdff71bca8771637a30372cd67f3
diff --git a/dev-perl/Net-OAuth/Net-OAuth-0.280.0-r1.ebuild b/dev-perl/Net-OAuth/Net-OAuth-0.280.0-r1.ebuild
new file mode 100644
index 000000000000..1d00d421e99f
--- /dev/null
+++ b/dev-perl/Net-OAuth/Net-OAuth-0.280.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=KGRENNAN
+MODULE_VERSION=0.28
+inherit perl-module
+
+DESCRIPTION="OAuth protocol support"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Accessor-0.31
+ >=dev-perl/Class-Data-Inheritable-0.06
+ dev-perl/Digest-HMAC
+ dev-perl/URI
+ virtual/perl-Digest-SHA
+ >=virtual/perl-Encode-2.35
+ dev-perl/libwww-perl
+"
+DEPEND="${RDEPEND}
+ dev-perl/Module-Build
+ test? (
+ >=virtual/perl-Test-Simple-0.66
+ >=dev-perl/Test-Warn-0.21
+ )"
+
+SRC_TEST=do
diff --git a/dev-perl/Net-OAuth/metadata.xml b/dev-perl/Net-OAuth/metadata.xml
new file mode 100644
index 000000000000..cdd31e9b7fe0
--- /dev/null
+++ b/dev-perl/Net-OAuth/metadata.xml
@@ -0,0 +1,32 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Net-OAuth</remote-id>
+ <remote-id type="cpan-module">Net::OAuth</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::AccessToken</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::AccessTokenRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::AccessTokenResponse</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::Client</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::ConsumerRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::Message</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::ProtectedResourceRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::Request</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::RequestTokenRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::RequestTokenResponse</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::Response</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::SignatureMethod::HMAC_SHA1</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::SignatureMethod::HMAC_SHA256</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::SignatureMethod::PLAINTEXT</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::SignatureMethod::RSA_SHA1</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::UserAuthRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::UserAuthResponse</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::V1_0A::AccessTokenRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::V1_0A::RequestTokenRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::V1_0A::RequestTokenResponse</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::V1_0A::UserAuthResponse</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::XauthAccessTokenRequest</remote-id>
+ <remote-id type="cpan-module">Net::OAuth::YahooAccessTokenRefreshRequest</remote-id>
+ </upstream>
+</pkgmetadata>