summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-16 16:05:04 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-16 23:49:50 +0100
commit951a9e0dac8b6c37491c2c90649e5f5543559c70 (patch)
tree76cdf3d1c30843049239fbc757a61a4d883851d0 /dev-perl/Path-Tiny
parentdev-perl/Test-MockRandom: Added to tree at version 1.10.0 (diff)
downloadgentoo-951a9e0dac8b6c37491c2c90649e5f5543559c70.tar.gz
gentoo-951a9e0dac8b6c37491c2c90649e5f5543559c70.tar.bz2
gentoo-951a9e0dac8b6c37491c2c90649e5f5543559c70.zip
dev-perl/Path-Tiny: Bump to version 0.84.0
- EAPI6 - Cleanup deps. - Make recommended deps optional Upstream: - New methods: assert, visit, edit{,_raw,_utf8}, edit_lines{,_raw,_utf8}, - lines() accepts negative count to fetch last lines - Exclusive locking options added to filehandle opens - copy() now returns a path() for the copied file - Spaces in tilde expansion no longer broken - realpath() no longer fatalizes if path_part[-1] is all that is missing - values returned to visit() only dereferenced if scalar refs. - Bug fixes in arg handling with File::Path - Fixed spewing to symlink that crosses fs boundary - relative() no longer implemented using File::Spec rel2abs Needs rekeywording for: ~arm ~hppa ~ppc Including: dev-perl/Test-MockRandom-1.10.0 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-perl/Path-Tiny')
-rw-r--r--dev-perl/Path-Tiny/Manifest1
-rw-r--r--dev-perl/Path-Tiny/Path-Tiny-0.84.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-perl/Path-Tiny/Manifest b/dev-perl/Path-Tiny/Manifest
index efc985dec345..49a6705b98a4 100644
--- a/dev-perl/Path-Tiny/Manifest
+++ b/dev-perl/Path-Tiny/Manifest
@@ -1,2 +1,3 @@
DIST Path-Tiny-0.044.tar.gz 48394 SHA256 57af7c250b4778c5045ec94ecb833796d74499e350a5bb0b816c97f2d7925f1a SHA512 a3a09254bbdc0d9dce7037ae4fb2c7bdbea29c19379337ea2f8ea6973e63a89961be5d058a571bcdb9810cbe95f7e9301207457725bda4f9536ecb93460f25e6 WHIRLPOOL b536b874c1d6b0522380c6ce4eebdc52033f9adcb6d377a1f0cd1b5c908c17e6816a0942fc153a81d85958467c6bd4a1d17122d087eed32d72e26696a24f8289
DIST Path-Tiny-0.061.tar.gz 71937 SHA256 e8290aac8c0623eea1b20b4a9d9a1be08db7f5a92ea51a514677964f3fa01cca SHA512 36efc16e8dc2046f4a0c458be464be54769ec721d09201970d7f4d9c87acb03b91f16b673e63fc8212574f47bad31f59006cc50eb242f071d271294408c397a0 WHIRLPOOL c0bf53e78b82a8f9351698de875dad339c821e3dccf5f7ee8add3ed7d3d11baacf43e5442d8481d1cdefce94da89e2d80eff28dbbaa1c6a5d6519e51a647d375
+DIST Path-Tiny-0.084.tar.gz 89052 SHA256 633f463e380404d4aaa8ebdd1977b5e387256aa2770eb142b169737978749bea SHA512 c8a5853f04afdb5d8db1e8f533d4706cf1030caefbb0f1b05f0fab7b71de34a0463269ba1733f549d1c1c7a370ce88f428d108387b10c6cb56c668280e2449c6 WHIRLPOOL ecf8a851796e958520e1433a4b4e7861b6c94a8ef215a41df7392d6414d9bd9df54aa7ca87f47a13f8c234ebc71d1b8aefdc5245c9c519e8cc42ecf7aa3abf43
diff --git a/dev-perl/Path-Tiny/Path-Tiny-0.84.0.ebuild b/dev-perl/Path-Tiny/Path-Tiny-0.84.0.ebuild
new file mode 100644
index 000000000000..9563d6fc8551
--- /dev/null
+++ b/dev-perl/Path-Tiny/Path-Tiny-0.84.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=DAGOLDEN
+DIST_VERSION=0.084
+inherit perl-module
+
+DESCRIPTION="File path utility"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ !minimal? (
+ >=dev-perl/Unicode-UTF8-0.580.0
+ )
+ virtual/perl-Carp
+ >=virtual/perl-Digest-1.30.0
+ >=virtual/perl-Digest-SHA-5.450.0
+ >=virtual/perl-Exporter-5.570.0
+ >=virtual/perl-File-Path-2.70.0
+ >=virtual/perl-File-Spec-0.860.0
+ >=virtual/perl-File-Temp-0.190.0
+ virtual/perl-if
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ !minimal? (
+ >=virtual/perl-JSON-PP-2.273.0
+ dev-perl/Test-FailWarnings
+ dev-perl/Test-MockRandom
+ )
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"