summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-26 20:16:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-26 20:25:14 +0300
commit37df2ec0b3f6b414af17a274d4d88ba71a036fd1 (patch)
tree7d81c7831b02d38c2ad7bb4a0130f59a74e28935 /dev-php
parentdev-php/symfony-event-dispatcher: treeclean (diff)
downloadgentoo-37df2ec0b3f6b414af17a274d4d88ba71a036fd1.tar.gz
gentoo-37df2ec0b3f6b414af17a274d4d88ba71a036fd1.tar.bz2
gentoo-37df2ec0b3f6b414af17a274d4d88ba71a036fd1.zip
dev-php/symfony-dependency-injection: treeclean
Closes: https://bugs.gentoo.org/934666 (pkgremoved) Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/symfony-dependency-injection/Manifest1
-rw-r--r--dev-php/symfony-dependency-injection/files/autoload.php15
-rw-r--r--dev-php/symfony-dependency-injection/metadata.xml22
-rw-r--r--dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild45
4 files changed, 0 insertions, 83 deletions
diff --git a/dev-php/symfony-dependency-injection/Manifest b/dev-php/symfony-dependency-injection/Manifest
deleted file mode 100644
index ce54999d9b20..000000000000
--- a/dev-php/symfony-dependency-injection/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST symfony-dependency-injection-2.8.50.tar.gz 117771 BLAKE2B b71535619a45a03640064b987a7b5996dc991458c737661a983782d7af53bf89865bf511dbac99384f8ece583b628a2cde0def2cdd3e8c133055d84d9dbed1e1 SHA512 690b3f373c2fb549115f7fdb35880a2c94bf7afa28be2c75d718373e8925897f89d5e34f82b709b11cd8940547289345a8def4debe657f495a0b636a6aa72baa
diff --git a/dev-php/symfony-dependency-injection/files/autoload.php b/dev-php/symfony-dependency-injection/files/autoload.php
deleted file mode 100644
index 4df35ec39a58..000000000000
--- a/dev-php/symfony-dependency-injection/files/autoload.php
+++ /dev/null
@@ -1,15 +0,0 @@
-<?php
-/* Autoloader for dev-php/symfony-dependency-injection and its dependencies */
-
-$vendorDir = '/usr/share/php';
-if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
- require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
-}
-
-\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\DependencyInjection\\', __DIR__);
-
-// Dependencies
-\Fedora\Autoloader\Dependencies::required(array(
- $vendorDir . '/Symfony/Component/Yaml/autoload.php',
- $vendorDir . '/Symfony/Component/Config/autoload.php',
-));
diff --git a/dev-php/symfony-dependency-injection/metadata.xml b/dev-php/symfony-dependency-injection/metadata.xml
deleted file mode 100644
index 25c9bf67dceb..000000000000
--- a/dev-php/symfony-dependency-injection/metadata.xml
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>guillaumeseren@gmail.com</email>
- <name>Guillaume Seren</name>
- </maintainer>
- <maintainer type="project" proxied="proxy">
- <email>proxy-maint@gentoo.org</email>
- <name>Proxy Maintainers</name>
- </maintainer>
- <maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- </maintainer>
- <longdescription>
- The DependencyInjection component allows you to standardize
- and centralize the way objects are constructed in your application.
- </longdescription>
- <upstream>
- <remote-id type="github">symfony/dependency-injection</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild b/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
deleted file mode 100644
index e7aa98e37382..000000000000
--- a/dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.50.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DESCRIPTION="Symfony DependencyInjection Component"
-HOMEPAGE="https://github.com/symfony/dependency-injection"
-SRC_URI="https://github.com/symfony/dependency-injection/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-# The test suite requires the unpackaged symfony-expression-language.
-RESTRICT=test
-
-# I'm not sure if symfony-config and symfony-yaml are actually needed if
-# you're not running the test suite...
-RDEPEND="dev-lang/php:*
- dev-php/fedora-autoloader
- >=dev-php/symfony-config-2.1.0
- >=dev-php/symfony-yaml-2.1.0"
-DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
-
-S="${WORKDIR}/dependency-injection-${PV}"
-
-src_prepare() {
- default
- if use test; then
- cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
- fi
-}
-
-src_install() {
- insinto "/usr/share/php/Symfony/Component/DependencyInjection"
- doins -r Compiler Dumper Exception Extension LazyProxy Loader ParameterBag
- doins *.php "${FILESDIR}/autoload.php"
- dodoc CHANGELOG.md README.md
-}
-
-src_test() {
- phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
-}