summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2020-06-11 03:43:32 +0200
committerDavide Pesavento <pesa@gentoo.org>2020-06-11 03:44:06 +0200
commitc5f61d6aafe4347cb0864aeaef0f564ec2e2ab17 (patch)
tree8b61dd648652635aeb22d769c8c51cb4c98e66db /dev-python/PyQtWebEngine
parentdev-python/PyQt5: add 5.15.0 (diff)
downloadgentoo-c5f61d6aafe4347cb0864aeaef0f564ec2e2ab17.tar.gz
gentoo-c5f61d6aafe4347cb0864aeaef0f564ec2e2ab17.tar.bz2
gentoo-c5f61d6aafe4347cb0864aeaef0f564ec2e2ab17.zip
dev-python/PyQtWebEngine: add 5.15.0
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-python/PyQtWebEngine')
-rw-r--r--dev-python/PyQtWebEngine/Manifest1
-rw-r--r--dev-python/PyQtWebEngine/PyQtWebEngine-5.15.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/PyQtWebEngine/Manifest b/dev-python/PyQtWebEngine/Manifest
index 8970a7199ab4..b4d308225b65 100644
--- a/dev-python/PyQtWebEngine/Manifest
+++ b/dev-python/PyQtWebEngine/Manifest
@@ -1 +1,2 @@
DIST PyQtWebEngine-5.14.0.tar.gz 47794 BLAKE2B 28f4a577ab5d8c1bea439b11e836008d27b4a49f31f230885013b515147a95c97e398328d1fc3a99619c3fd6eca3da7e94bf5873de9ac6511e0f59e467d4490c SHA512 c5274ce5ba1c80c6851971c3e18acf33121cd5863f613bd1789fdb40323b52429b55b54f3dcbb3127c85343e11f14c004ad54711b2b59cab95fd440f90fe5f2e
+DIST PyQtWebEngine-5.15.0.tar.gz 48308 BLAKE2B 18a0b83c245a738f144cb21ddc483646099dc6469b0ecfe634d0341c555db17724cb97901082d2d93668a9e64b9163496afba8d7928f8e49013bcdcdb3747105 SHA512 9bc74e4c7c49a42a5a1a75c75cf14d30e7e9202b6f98591d79dd7f47d44909a1c95a1b38cd47adc8182429c43d1d45d90b2c3d0f105b90ed7ebfbb33a2622322
diff --git a/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.0.ebuild b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.0.ebuild
new file mode 100644
index 000000000000..4d322572d51e
--- /dev/null
+++ b/dev-python/PyQtWebEngine/PyQtWebEngine-5.15.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+inherit python-r1 qmake-utils
+
+DESCRIPTION="Python bindings for QtWebEngine"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqtwebengine/intro"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/PyQt5-5.14[gui,network,printsupport,ssl,webchannel,widgets,${PYTHON_USEDEP}]
+ >=dev-python/PyQt5-sip-4.19.22:=[${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtwebengine:5[widgets]
+"
+DEPEND="${RDEPEND}
+ >=dev-python/sip-4.19.22[${PYTHON_USEDEP}]
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ configuration() {
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --qmake="$(qt5_get_bindir)"/qmake
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Fix parallel install failure
+ sed -i -e '/INSTALLS += distinfo/i distinfo.depends = install_subtargets install_pep484_stubs install_api' \
+ ${PN}.pro || die
+
+ # Run eqmake to respect toolchain and build flags
+ eqmake5 -recursive ${PN}.pro
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+
+ einstalldocs
+}