summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-03-31 21:32:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-03-31 21:46:53 +0300
commit1e542fa6ccaf6749301512b56fe07eeb57b807e4 (patch)
tree1c94d946959e4fdacd3991b04e4a3b3424fcd587 /dev-python/aiodns
parentdev-python/python-redmine: add 2.5.0 (diff)
downloadgentoo-1e542fa6ccaf6749301512b56fe07eeb57b807e4.tar.gz
gentoo-1e542fa6ccaf6749301512b56fe07eeb57b807e4.tar.bz2
gentoo-1e542fa6ccaf6749301512b56fe07eeb57b807e4.zip
dev-python/aiodns: add 3.2.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-3.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index 247d546a18e6..238836382033 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1 +1,2 @@
DIST aiodns-3.1.1.tar.gz 7363 BLAKE2B bb5a465be00ff61406b61cef133cb5eed8e007114ddcd1475a12fed5481ec377bc96291fdc7fd6cc5936de865118f7008625ec5d69c09f96eacdb83b4b29c786 SHA512 7c28cc6256a575681778376cc197a9504133b1127eb3508f6e5cd1c992c95adef66cf8399b7e90ca012347485e476f71e3f032f7e2f555954ad9a0cade8df5f9
+DIST aiodns-3.2.0.tar.gz 7823 BLAKE2B 8bafeebbf6ef69001670dffe8df3bd89b817bca921e266e218eaf2a53653d5bb150cef0c99b2fd498d39befb57c6e2edb4d94fbf4b4548e1debce69bcd114ff3 SHA512 ca6ae2d53cc0a0e5b8cd5f47da56d7db43236eb6738509d5cc088e56db996c49eba8b024cfe368e5acf44ad4de4cb5d6f949c7f0d4cd16ff4d5cc42ae3b27cb1
diff --git a/dev-python/aiodns/aiodns-3.2.0.ebuild b/dev-python/aiodns/aiodns-3.2.0.ebuild
new file mode 100644
index 000000000000..04f4bea5d751
--- /dev/null
+++ b/dev-python/aiodns/aiodns-3.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="
+ https://pypi.org/project/aiodns/
+ https://github.com/saghul/aiodns/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet changed, https://github.com/saghul/aiodns/issues/107
+ tests.py::DNSTest::test_query_bad_chars
+ )
+
+ epytest tests.py
+}