summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-10 04:30:56 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-10 04:33:32 +0200
commit6c3bc28a4ab8a5b500fbd5e48f01acfeccf2bf42 (patch)
treef3b71d274c9ed37866358043a5872153ad830812 /dev-python/aiofiles
parentdev-python/hcloud: Bump to 1.27.2 (diff)
downloadgentoo-6c3bc28a4ab8a5b500fbd5e48f01acfeccf2bf42.tar.gz
gentoo-6c3bc28a4ab8a5b500fbd5e48f01acfeccf2bf42.tar.bz2
gentoo-6c3bc28a4ab8a5b500fbd5e48f01acfeccf2bf42.zip
dev-python/aiofiles: Bump to 23.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiofiles')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-23.2.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index 7f579a41086b..d308d58881a9 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1,2 +1,3 @@
DIST aiofiles-22.1.0.gh.tar.gz 21630 BLAKE2B 8f068046fc143388debc93b657f8b4715cd48eac7e7b8a031ccdc6d2f5764ddcafb2ad1fab713ca55366cad951b570e1c2a120932bf5545482e1a3f086a76bf9 SHA512 6706fb7b6fd32df415ece64f35b8ccc2f263301c43292612b2b6173fb66c77bc88fd08ed0b0bb30fa3dd49571be8fc733a3d4f3611228fdbb368743588336357
DIST aiofiles-23.1.0.gh.tar.gz 30110 BLAKE2B c6cb0880cc761d3c34eefbda373a361a3f20bc6e37c81c769609b149dd13ff6cf9f169d63cbde9d02cd91a49d03198705576389c531a82fcd614e7b464bdafe8 SHA512 7afbc492061df6b5e76514d36938ec39e3261fbf0c3123d38f1d32cc1d335603d6ab681c088d9c68ef5be9fc9b9eec1b460268b03d5f6409213bf20ec87dde47
+DIST aiofiles-23.2.1.tar.gz 32072 BLAKE2B 9718fe7f4367b30ca295efb39ffeab0c77ca54ed1c4f556b0b39f5abb540d4f23c6e8a49aa5b6b76c0692e393bbab7c8d252de4b0f6f4f423b74e88c43483e08 SHA512 defc9d1ff5351c1812432db1849233b1f0aa661f6420c79a6eb17d84c0622ee4dd5102d50e9ef920c91adcc48914a39cd62701b340b01806a83773bf05900b6f
diff --git a/dev-python/aiofiles/aiofiles-23.2.1.ebuild b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
new file mode 100644
index 000000000000..07e3521a9791
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-23.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest