summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-20 08:49:34 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-20 11:10:10 +0100
commit595c798794e340fdf91794fb15d436039e37b675 (patch)
tree60eddcedf2dab53d8b0a5eda2f62c95a2fb519a9 /dev-python/aiosmtpd
parentdev-python/boto3: Bump to 1.17.12 (diff)
downloadgentoo-595c798794e340fdf91794fb15d436039e37b675.tar.gz
gentoo-595c798794e340fdf91794fb15d436039e37b675.tar.bz2
gentoo-595c798794e340fdf91794fb15d436039e37b675.zip
dev-python/aiosmtpd: Bump to 1.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest1
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.3.2.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
index 8b556c8d1d92..266ab9d2f22b 100644
--- a/dev-python/aiosmtpd/Manifest
+++ b/dev-python/aiosmtpd/Manifest
@@ -1,3 +1,4 @@
DIST aiosmtpd-1.2.2.tar.gz 170459 BLAKE2B abf178c28a21c25e8a7c7ed920c154f037aaa21da5d2dfa0ee8cae7d239d00d5a979eedfb3865e3de7e54e7da94ea8a1e6b5194681a2137ac7d8f0f69d82e3a6 SHA512 7ffc279a73685601496dbfffef30a78cc254a76f8c8fccd0c7b7efe41da66672f0d8662f302eb928e90eb8977b859cb7e713415d0aa5e93f369ef23bdff405fc
DIST aiosmtpd-1.2.4.tar.gz 83329 BLAKE2B accecbc3fe66efc748d0bc3c85504d731005b907435fada5b3c7ae0f7778e89f19d7c15a7edb194a7ba6310a450132728557a441b3fb2958d3658b0a15d3ccf5 SHA512 dc6041e284daceb89f8ca83b5cd715a5811eb4cf76504c23112e24c97d6c88480667c713ce094c2dcbc5b12a80605e551b6aadc4b1ce499089be68c7c4e7df8c
DIST aiosmtpd-1.2.tar.gz 51457 BLAKE2B c2dba38c5d5a243a65c332cb3b6bf85a124eb6ab9c3526d0ef57788eb7e24e64ec86c56eeaa57e5171631c8a965447f125366741b1d1c54fb48473da5123ed40 SHA512 520b0fae80423d3963d4f17ef393cc0ce9e342fd1237c909159706bfe1e13f27df849fbc14aa1c94ad02e7c9108308984b6f9e21c7dbddb09093ef00884983d8
+DIST aiosmtpd-1.3.2.tar.gz 110769 BLAKE2B 985684d8183c89670c362e39b81cbff187fa820bc3197a0c0c18cd61eb4c00912bf489d935303be0fedfee3dabfafaf81c7d4be3e428374624ed9a1fab6ce2c8 SHA512 b5d183671b8a985dcf774fb1b35ffbdf5c058e24e7cb81d77b2b0ce00b2b4dff27ff8bb167e985d5bf84cb6816c014d7cd601aab59243136ae409975ef3da30d
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.3.2.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.3.2.ebuild
new file mode 100644
index 000000000000..495f26fa447f
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.3.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio based SMTP server"
+HOMEPAGE="https://aiosmtpd.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/atpublic[${PYTHON_USEDEP}]
+ dev-python/attrs[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest