summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-31 23:34:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-01 00:46:53 +0100
commitae231920562e1c3f1122367ff4c53f7484cd0ffb (patch)
treec8b8e8e1542ed442aef3f40c13181ff1ae61e8fe /dev-python/ansi
parentdev-python/google-auth: Bump to 2.6.0 (diff)
downloadgentoo-ae231920562e1c3f1122367ff4c53f7484cd0ffb.tar.gz
gentoo-ae231920562e1c3f1122367ff4c53f7484cd0ffb.tar.bz2
gentoo-ae231920562e1c3f1122367ff4c53f7484cd0ffb.zip
dev-python/ansi: Bump to 0.3.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ansi')
-rw-r--r--dev-python/ansi/Manifest1
-rw-r--r--dev-python/ansi/ansi-0.3.5.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/ansi/Manifest b/dev-python/ansi/Manifest
index dba5288bc241..b45fe7261f74 100644
--- a/dev-python/ansi/Manifest
+++ b/dev-python/ansi/Manifest
@@ -1 +1,2 @@
DIST ansi-0.2.0.tar.gz 5173 BLAKE2B 436caa8e1f36e96f1844e79e3a0ff0c4099e76b25ce9f56c9d8663aeeb650f32fba75a14fe8548f557fb020e2340707272fdda4cdd3c245c903a4f801ae48413 SHA512 22c69b5030f03eca9470e288c16e62042ccd02ef2e232600a4fab629354601d5da0f7c16b60dae7293c69255e5d4125298890d99dba8e5387960a5be60b92d61
+DIST ansi-0.3.5.tar.gz 6597 BLAKE2B 4e32bd7add4af1d9f11173aa79d6ed139814f3b3727a4599f104e8632a4e169fdaccf3e18ecf425f86c17c70c1d185f6a915bd9cbac2589d376fc23c338127e6 SHA512 a12b7e1231c2691edf6d807907fe6b8a8d6c6bc116fd9681b6bb7603e6e2ce7af17e3e7892d4046752844327eb8f02a248f93686640bec24dbe2be59202b01e3
diff --git a/dev-python/ansi/ansi-0.3.5.ebuild b/dev-python/ansi/ansi-0.3.5.ebuild
new file mode 100644
index 000000000000..838f9f8f9f2e
--- /dev/null
+++ b/dev-python/ansi/ansi-0.3.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI cursor movement and graphics in Python"
+HOMEPAGE="https://github.com/tehmaze/ansi/"
+SRC_URI="https://github.com/tehmaze/${PN}/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest