summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-15 08:55:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-15 10:04:03 +0200
commitc8095cdeba00a167d2ff20ec82f7e7380237cdda (patch)
tree21a2d630cc8de3e1de143d1ec2500fee371d3bc5 /dev-python/apispec
parentdev-python/braintree: Bump to 4.17.1 (diff)
downloadgentoo-c8095cdeba00a167d2ff20ec82f7e7380237cdda.tar.gz
gentoo-c8095cdeba00a167d2ff20ec82f7e7380237cdda.tar.bz2
gentoo-c8095cdeba00a167d2ff20ec82f7e7380237cdda.zip
dev-python/apispec: Bump to 6.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-6.0.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 240313387eaa..30aca0a94cdd 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-5.2.2.gh.tar.gz 71563 BLAKE2B 205c796ccee03000626538147d6cb26a72242ba8ffd6df47b6a7bdb82f0e2ee1d5421cb7da045fc177297acb838e7351ae996225a43c3c7a57a0a0d72e098bb1 SHA512 16c6229619853671403e81edaa50ce87c2575cdb6c606502e08c086aa33b25db0cef0cd455c2c74a55138eaf95667f7ffe9ac8045cbeb415df4b623878a8831c
+DIST apispec-6.0.0.gh.tar.gz 72200 BLAKE2B c65278602c7f05074bf6e4e36a5e7aeaf0eabcc281c387448666f6958eef95a4f4f297055f58eb580169249cc90c1643bcdef0f9281792e4840d719cc921c9f3 SHA512 4c4c34554241fba67d0aad41aa81e5c6e97ee42003da503afa223ff5fbf0046a8b5f3dc3835fe9ae1dc03181f4be5fabae1a7d80871c0a061602d2593315b2db
diff --git a/dev-python/apispec/apispec-6.0.0.ebuild b/dev-python/apispec/apispec-6.0.0.ebuild
new file mode 100644
index 000000000000..b82fa25e0226
--- /dev/null
+++ b/dev-python/apispec/apispec-6.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)