summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-21 15:24:50 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-21 15:40:24 +0200
commite0be7fcacfe52147962469b89d6979c34f3ab226 (patch)
tree1d89004ebcf0122a49de5762cb64f36ecde90dbc /dev-python/astropy
parentdev-python/h5py: Add python3.5 support (diff)
downloadgentoo-e0be7fcacfe52147962469b89d6979c34f3ab226.tar.gz
gentoo-e0be7fcacfe52147962469b89d6979c34f3ab226.tar.bz2
gentoo-e0be7fcacfe52147962469b89d6979c34f3ab226.zip
dev-python/astropy: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/astropy')
-rw-r--r--dev-python/astropy/astropy-1.0.5.ebuild2
-rw-r--r--dev-python/astropy/astropy-9999.ebuild89
-rw-r--r--dev-python/astropy/files/astropy-9999-system-pytest.patch16
3 files changed, 106 insertions, 1 deletions
diff --git a/dev-python/astropy/astropy-1.0.5.ebuild b/dev-python/astropy/astropy-1.0.5.ebuild
index 3a3666e1b901..8b93665a1a94 100644
--- a/dev-python/astropy/astropy-1.0.5.ebuild
+++ b/dev-python/astropy/astropy-1.0.5.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
inherit distutils-r1
diff --git a/dev-python/astropy/astropy-9999.ebuild b/dev-python/astropy/astropy-9999.ebuild
new file mode 100644
index 000000000000..634d5beb5eb7
--- /dev/null
+++ b/dev-python/astropy/astropy-9999.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Core functionality for performing astrophysics with Python"
+HOMEPAGE="http://astropy.org/"
+EGIT_REPO_URI="https://github.com/astropy/astropy.git"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-libs/expat-2.1.0:0=
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=sci-astronomy/erfa-1.2:0=
+ >=sci-astronomy/wcslib-4.25:0=
+ >=sci-libs/cfitsio-3.350:0=
+ sys-libs/zlib:0="
+DEPEND="${RDEPEND}
+ dev-python/astropy-helpers[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ dev-libs/libxml2[${PYTHON_USEDEP}]
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.4-disable_helper.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-six.patch"
+ "${FILESDIR}/${P}-system-pytest.patch"
+ "${FILESDIR}/${PN}-1.0.4-system-configobj.patch"
+ )
+
+python_prepare_all() {
+ export mydistutilsargs="--offline"
+ rm -r ${PN}_helpers || die
+ cp "${FILESDIR}"/astropy-ply.py astropy/extern/ply.py || die
+ rm -r cextern/{expat,erfa,cfitsio,wcslib} || die
+ #rm -rvf ${PN}/extern/* || die
+ #{configobj,{six,pytest,configobj}.py} || die
+
+ cat >> setup.cfg <<-EOF
+
+ [build]
+ use_system_libraries=1
+ EOF
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ python_export_best
+ VARTEXFONTS="${T}"/fonts \
+ MPLCONFIGDIR="${BUILD_DIR}" \
+ PYTHONPATH="${BUILD_DIR}"/lib \
+ esetup.py build_sphinx
+ fi
+}
+
+python_test() {
+ py.test -vv -k "not test_web_profile" astropy || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/astropy/files/astropy-9999-system-pytest.patch b/dev-python/astropy/files/astropy-9999-system-pytest.patch
new file mode 100644
index 000000000000..19b321d2a019
--- /dev/null
+++ b/dev-python/astropy/files/astropy-9999-system-pytest.patch
@@ -0,0 +1,16 @@
+ astropy/tests/helper.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/astropy/tests/helper.py b/astropy/tests/helper.py
+index 97d2617..a75db15 100644
+--- a/astropy/tests/helper.py
++++ b/astropy/tests/helper.py
+@@ -42,7 +42,7 @@ __all__ = ['raises', 'enable_deprecations_as_exceptions', 'remote_data',
+ 'pickle_protocol', 'generic_recursive_equality_test']
+
+
+-if os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
++if True or os.environ.get('ASTROPY_USE_SYSTEM_PYTEST') or '_pytest' in sys.modules:
+ import pytest
+
+ else: