summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-04 09:03:45 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-04 09:17:28 +0100
commit8a3c8995d0a518cf553edc9117ad745e3f4266ca (patch)
tree22af904e04a35cdcdd2d8e16fb1da752d97f3419 /dev-python/autopep8
parentnet-misc/youtube-dl: Bump to 2021.02.04.1 (diff)
downloadgentoo-8a3c8995d0a518cf553edc9117ad745e3f4266ca.tar.gz
gentoo-8a3c8995d0a518cf553edc9117ad745e3f4266ca.tar.bz2
gentoo-8a3c8995d0a518cf553edc9117ad745e3f4266ca.zip
dev-python/autopep8: Bump to 1.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-1.5.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 9aa3f008aebd..f45a7f8091fa 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-1.5.4.tar.gz 121471 BLAKE2B 4d9d4d0de94757573ad56636d92983d0bedfb2c7a3f25a47d8dba9c78c4e0752aa2ea0cd43f93d9cf37e434178cf89ad6c98b2af3a07f2490147c87a95ff610a SHA512 e613295d080149028361715f748fc9db1b7fc6212ca4e117594a10c3924a67eaad6ff8d94cfcf2c3dea087e0aa1ce6bcadc1b4eb3f07915daa5b002a09913f59
+DIST autopep8-1.5.5.tar.gz 117991 BLAKE2B 74e9bfed663d68f4a73088fccd879c538d40c564e7527b067d549a15361dfba2adcb853a8895fc61da50972f947ce23900f8067f5b8e715f73d6a80c6c27ef5b SHA512 9982271805131a7330d4a2a46eda65c05f079925393686f2df7eb92dc9e172003f9d788663cb8c0c8849dbae4f64c518c310eb65c3df308a12700abab084c39c
diff --git a/dev-python/autopep8/autopep8-1.5.5.ebuild b/dev-python/autopep8/autopep8-1.5.5.ebuild
new file mode 100644
index 000000000000..daf7a5d94067
--- /dev/null
+++ b/dev-python/autopep8/autopep8-1.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="https://github.com/hhatto/autopep8 https://pypi.org/project/autopep8/"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]"
+BDEPEND="test? ( dev-python/pydiff[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests setup.py