summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-24 08:21:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-24 08:41:40 +0200
commitee1b9775dad8c84ac6caa392727c4c21c524e5c4 (patch)
tree766639ad459f78ffca70763c66f5a27f16e140e8 /dev-python/bandit
parentdistutils-r1.eclasS: Switch scikit-build-core to build.verbose (diff)
downloadgentoo-ee1b9775dad8c84ac6caa392727c4c21c524e5c4.tar.gz
gentoo-ee1b9775dad8c84ac6caa392727c4c21c524e5c4.tar.bz2
gentoo-ee1b9775dad8c84ac6caa392727c4c21c524e5c4.zip
dev-python/bandit: Bump to 1.7.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bandit')
-rw-r--r--dev-python/bandit/Manifest1
-rw-r--r--dev-python/bandit/bandit-1.7.10.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bandit/Manifest b/dev-python/bandit/Manifest
index 876f2cd9cff9..ebbc7a5d2c01 100644
--- a/dev-python/bandit/Manifest
+++ b/dev-python/bandit/Manifest
@@ -1 +1,2 @@
+DIST bandit-1.7.10.tar.gz 4228540 BLAKE2B ca1fdbd5061a635520500cb583b739d19335920eeb89661c7ddf2a2c3a97d3c55c2ce7797be984dd1dba2613a38d6b2e0bbcfde655f9d4ed76582ce831e4b42e SHA512 c9c5d098186a23f856f4bdecdebfe863f7ddce8627608b80c62a537416d2aa91666a95c304f5cdde43ff1a41e1f6a58b30dce1042159a1ea74b8b5c9a8ee381a
DIST bandit-1.7.9.tar.gz 4225771 BLAKE2B e5d20fbf4c3a33b092c23ad356dad39543ccea4d552687b97350cb6fe960dfa004cbef627ee0e0911da147ed53c6eb57046ec57c76858c58e772bf81e2c2b82e SHA512 a71e3eb359fad952afc9e210795fb8cc6fe178305bb837e002af83eccc4a958664b69422ba93d7d72b24089ba3142667ca17909d712db1b447e78d6f7f4c9634
diff --git a/dev-python/bandit/bandit-1.7.10.ebuild b/dev-python/bandit/bandit-1.7.10.ebuild
new file mode 100644
index 000000000000..608a06da92cc
--- /dev/null
+++ b/dev-python/bandit/bandit-1.7.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A security linter from OpenStack Security"
+HOMEPAGE="
+ https://github.com/PyCQA/bandit/
+ https://pypi.org/project/bandit/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-3.1.30[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/beautifulsoup4-4.8.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jschema-to-python-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/pylint-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/sarif-om-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ ' 3.10)
+ )
+"
+
+distutils_enable_tests unittest