summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-20 06:48:05 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-20 06:48:54 +0200
commit6b64416800eb55a0e1c3319cefbab1b528b22b32 (patch)
treefa32fdbab7c4b1b7a63f2b9c48a7b00f28f3f933 /dev-python/beartype
parentdev-python/sqlglot: Bump to 25.22.0 (diff)
downloadgentoo-6b64416800eb55a0e1c3319cefbab1b528b22b32.tar.gz
gentoo-6b64416800eb55a0e1c3319cefbab1b528b22b32.tar.bz2
gentoo-6b64416800eb55a0e1c3319cefbab1b528b22b32.zip
dev-python/beartype: Bump to 0.19.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beartype')
-rw-r--r--dev-python/beartype/Manifest1
-rw-r--r--dev-python/beartype/beartype-0.19.0_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/beartype/Manifest b/dev-python/beartype/Manifest
index 1d5b0b7f9647..8718c889444a 100644
--- a/dev-python/beartype/Manifest
+++ b/dev-python/beartype/Manifest
@@ -1,2 +1,3 @@
DIST beartype-0.18.5.tar.gz 1193506 BLAKE2B 497de6f326a3b600992748db8b74ba80d4a14003a0cc484b3eeaf48f0f808864fe64462ef3315d421dc4b5fe5d7060b48585ee00eb822c9f124612f394ab93bb SHA512 114b256619c6c7fc48fbe28db00ae5a8ddea4ce11c5394a06fa026f0317a34907ff12ef0c0009cff7a7b83742e6b66bc8b503b4c0e382c0b6cf79d43780bda5b
DIST beartype-0.19.0rc1.tar.gz 1281359 BLAKE2B df124c838891e5bbce62ac8116968631887dc5e5918a1b6a7c46c1705d05fcacf5f4cc4034b39a6d8565a78e2edd99686643a0d1d8c22586cfd797ceb8085b29 SHA512 630fd68a55ab379aca7b49b72161b732e0790835d7f62568239fb53f719fc8295bbe3c942058ab6dfad3226060a5a11820bc87080a2dcfb46c482e1877f775b7
+DIST beartype-0.19.0rc2.tar.gz 1294713 BLAKE2B 7197c8203cd9d1a750df3946a19ad9d0be893b649f89254462edadbabb49adfda3e098b35b21fcc92156c5ea488b2e7760cf6bf18f418530533495be9694b71c SHA512 ea9bd08f9b294382826201e4bded03fb7337e5fd5ed3d63fa741703b49164ad7dd3075ccaf3256011005c31cce4258efb9070f876009eece49bbfd2bffb5196a
diff --git a/dev-python/beartype/beartype-0.19.0_rc2.ebuild b/dev-python/beartype/beartype-0.19.0_rc2.ebuild
new file mode 100644
index 000000000000..000466fffd5b
--- /dev/null
+++ b/dev-python/beartype/beartype-0.19.0_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Unbearably fast runtime type checking in pure Python"
+HOMEPAGE="
+ https://pypi.org/project/beartype/
+ https://github.com/beartype/beartype/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ test? (
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fragile performance test
+ beartype_test/a00_unit/a70_decor/test_decorwrapper.py::test_wrapper_fail_obj_large
+ # test for building docs, apparently broken too
+ beartype_test/a90_func/z90_lib/a00_sphinx
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}