summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-02 03:00:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-02 03:37:04 +0200
commit0fdc7fa40f53fc75d79ca9ada6c61c0c4b7165ac (patch)
treedd873ecc7a32bceaaa85eeed38df2a9bbbe392e7 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.96 (diff)
downloadgentoo-0fdc7fa40f53fc75d79ca9ada6c61c0c4b7165ac.tar.gz
gentoo-0fdc7fa40f53fc75d79ca9ada6c61c0c4b7165ac.tar.bz2
gentoo-0fdc7fa40f53fc75d79ca9ada6c61c0c4b7165ac.zip
dev-python/boto3: Bump to 1.34.96
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.96.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index daed121dc334..f8f482ec2f91 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.88.gh.tar.gz 798806 BLAKE2B 2d3e02f0584e138a75acb68593bd88126641
DIST boto3-1.34.93.gh.tar.gz 802078 BLAKE2B 43f19efd6ae42bdb20e8dd79b1735df229ec2f231b5fe05006b26fcd5ddf4796a53fba6011c298fb919ee7b205b4ae3f4b563ad3b5325bdbbdebaeab7be59608 SHA512 4da1d9d7d8648e895f23763e5055a868d05bbfd8eb28d56e716975b3b8349bd1825d703f6fd11c316174004c39e1fca5ddcd8a4ad27a000e1a52f08a36eb4780
DIST boto3-1.34.94.gh.tar.gz 803022 BLAKE2B fcc522fc68e31fae8086e21740e7ac286f4d2b38caa8a970d7c7851288eec35bd05853410bcfe8bd2bd3a0be52b89386b6c600d9c465ce63470fb0cbe863a345 SHA512 d341e3e3720e4c647e1f5ec578b8f55740f21df4430bbe1ff5e6de11c23126ceb68c956570778af03a0703798468733078c929b75612f6143bd24f929e861fb8
DIST boto3-1.34.95.gh.tar.gz 804506 BLAKE2B 81bc8a68138e391dca19894fb42eb9c55b155463bf7baa4dbd5ab876d94e6a4174eefe23938990e64bc0e6391e46ab764436c2ef0debb544f204ac1e5321212a SHA512 efc8df42dc0b65061e564ed60996a750e43feb44ef9c71f58dec04e3c2644172f2fc19f01ed877f8c1a29da2ba367bbfb2d77085e5443e9b84ef003de2bf6e50
+DIST boto3-1.34.96.gh.tar.gz 804809 BLAKE2B 7dfdf70f817d4f0c69f67b96f329ce4cf939f2c5cb87208faecbb160c304ef9bc0342929a336b159331dfb80a68b49e4d07d3324a7df3e60ea33a440483bc9c8 SHA512 4ef57ced14d6a882e2b3358cbedc632a00f1d55a70d831ba597e7ff785e44ab0e37882373d07e0385be830f5c940f7cba6b0f0b6ddeea65640c07d0083ea98e7
diff --git a/dev-python/boto3/boto3-1.34.96.ebuild b/dev-python/boto3/boto3-1.34.96.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.96.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}