summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-30 04:31:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-10-30 04:33:56 +0100
commit024dc37cca0eec72663e13e8b0e04fa655685893 (patch)
tree8ffa1ba7869cd7ad972ada9883944ae79adc48b1 /dev-python/braintree
parentdev-python/braintree: Remove old (diff)
downloadgentoo-024dc37cca0eec72663e13e8b0e04fa655685893.tar.gz
gentoo-024dc37cca0eec72663e13e8b0e04fa655685893.tar.bz2
gentoo-024dc37cca0eec72663e13e8b0e04fa655685893.zip
dev-python/braintree: Bump to 4.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/braintree')
-rw-r--r--dev-python/braintree/Manifest1
-rw-r--r--dev-python/braintree/braintree-4.31.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/braintree/Manifest b/dev-python/braintree/Manifest
index 7aef06c6bd6d..e2da559e6d3c 100644
--- a/dev-python/braintree/Manifest
+++ b/dev-python/braintree/Manifest
@@ -1 +1,2 @@
DIST braintree_python-4.30.0.gh.tar.gz 230547 BLAKE2B b789ee0ff9fe925c1db5dc005aae78efca7736e3047c9151329f957862d4c6b145e9d152882c89bfe9240205de38283c40873db087f053bf55c9edaae666d848 SHA512 89fced2e4b69e71b56cac68b694e65f55574dbd84953000f0c8e82743869d72481570f836f721375f91766c1b0963bfec51a2657f732df1f8a4fd2130ce27c60
+DIST braintree_python-4.31.0.gh.tar.gz 239483 BLAKE2B 959f039fa98a6acefb9b114bf8c7fef6d9b848f0a9c2e36dac86704df2e228604b316092022bfa2624c6d5688011e2ad85db6b2270736522497b67bfdbd8a2ff SHA512 5a29ab736f3c535c1e54f9210a148059833d1b56d073a0190407f103b65719cfdd02b3dd77ec61298127017dcc8bc4be0478aba2b386358169f5aaba264f19ea
diff --git a/dev-python/braintree/braintree-4.31.0.ebuild b/dev-python/braintree/braintree-4.31.0.ebuild
new file mode 100644
index 000000000000..42722b55e6d7
--- /dev/null
+++ b/dev-python/braintree/braintree-4.31.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+MY_P=braintree_python-${PV}
+DESCRIPTION="Braintree Python Library"
+HOMEPAGE="
+ https://developer.paypal.com/braintree/docs/reference/overview/
+ https://github.com/braintree/braintree_python/
+ https://pypi.org/project/braintree/
+"
+# no tests in sdist, as of 4.19.0
+SRC_URI="
+ https://github.com/braintree/braintree_python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-0.11.0[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests/unit
+}