summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-16 23:15:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-16 23:15:38 +0200
commit82b4d6250eab5e0350069bc76cf893730bfe5c81 (patch)
tree2bb778db8c39ef83af8fa8d0b378d09d148e2180 /dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
parentnet-misc/freerdp: fix build with ffmpeg git master. (diff)
downloadgentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.tar.gz
gentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.tar.bz2
gentoo-82b4d6250eab5e0350069bc76cf893730bfe5c81.zip
dev-python/catkin_pkg: Initial import. Ebuild by me.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild')
-rw-r--r--dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild b/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
new file mode 100644
index 000000000000..b5bb86f49806
--- /dev/null
+++ b/dev-python/catkin_pkg/catkin_pkg-0.2.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/ros-infrastructure/catkin_pkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the catkin package system"
+HOMEPAGE="http://wiki.ros.org/catkin_pkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="
+ http://download.ros.org/downloads/${PN}/${P}.tar.gz
+ http://github.com/ros-infrastructure/catkin_pkg/archive/${PV}.tar.gz -> ${P}.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )
+"
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
+
+python_test() {
+ nosetests -s --tests test || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ # Avoid recursing in the whole hierarchy
+ dodir /usr/
+ touch "${ED}/usr/CATKIN_IGNORE"
+}