summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 08:26:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 08:54:16 +0200
commit4989b28d138b650e5bd1ca9d0a84b53c967f710f (patch)
treedd56aa775bfc65c8947efb67218198c7da2aee3c /dev-python/certifi
parentdev-python/flaky: Remove old (diff)
downloadgentoo-4989b28d138b650e5bd1ca9d0a84b53c967f710f.tar.gz
gentoo-4989b28d138b650e5bd1ca9d0a84b53c967f710f.tar.bz2
gentoo-4989b28d138b650e5bd1ca9d0a84b53c967f710f.zip
dev-python/certifi: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/certifi')
-rw-r--r--dev-python/certifi/certifi-3021.3.16-r1.ebuild60
-rw-r--r--dev-python/certifi/files/certifi-3021.3.16-setuptools.patch21
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/certifi/certifi-3021.3.16-r1.ebuild b/dev-python/certifi/certifi-3021.3.16-r1.ebuild
deleted file mode 100644
index cc5fde7ec874..000000000000
--- a/dev-python/certifi/certifi-3021.3.16-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-inherit distutils-r1
-
-MY_P=certifi-system-store-${PV}
-DESCRIPTION="A certifi hack to use system trust store on Linux/FreeBSD"
-HOMEPAGE="
- https://github.com/tiran/certifi-system-store/
- https://pypi.org/project/certifi-system-store/"
-SRC_URI="
- https://github.com/tiran/certifi-system-store/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-RDEPEND="app-misc/ca-certificates"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3021.3.16-setuptools.patch
-)
-
-EPYTEST_IGNORE=(
- # requires Internet
- tests/test_requests.py
-)
-
-distutils_enable_tests --install pytest
-
-src_prepare() {
- sed -i -e "s^/etc^${EPREFIX}/etc^" src/certifi/core.py || die
- distutils-r1_src_prepare
-}
-
-symlink_info() {
- pushd "${1}" >/dev/null || die
- local egginfo=( certifi_system_store*.egg-info )
- [[ -d ${egginfo} ]] || die
- ln -v -s "${egginfo}" "${egginfo/_system_store}" || die
- popd >/dev/null || die
-}
-
-python_test() {
- distutils_install_for_testing
- symlink_info "${TEST_DIR}"/lib
- epytest
-}
-
-python_install() {
- distutils-r1_python_install
- symlink_info "${D}$(python_get_sitedir)"
-}
diff --git a/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch b/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch
deleted file mode 100644
index 57154fd0eed9..000000000000
--- a/dev-python/certifi/files/certifi-3021.3.16-setuptools.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-https://github.com/tiran/certifi-system-store/pull/17
-https://bugs.gentoo.org/822777
-
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 23 Nov 2021 15:56:33 +0100
-Subject: [PATCH] Add missing install_requires on setuptools
-
-This package is using pkg_resources explicitly, it should therefore
-declare an explicit dependency on setuptools. The missing dependency
-has lead me to actually miss the runtime dependency which caused issues
-for Gentoo users for whom setuptools were cleaned.
---- a/setup.cfg
-+++ b/setup.cfg
-@@ -40,6 +40,7 @@ zip_safe = True
- setup_requires = setuptools
- # hack to prevent installation on unsupported platforms Windows and macOS
- install_requires =
-+ setuptools
- certifi-system-store > 4000; sys_platform == "win32" or sys_platform == "darwin"
- python_requires = >=3.6
-