summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-23 07:28:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-23 08:16:20 +0200
commit68f241973f415ff601304b942892dc96a9c18567 (patch)
tree176c228b4f9549a3c4c191b26aac03f485108b15 /dev-python/cftime
parentdev-python/sqlglot: Bump to 25.27.0 (diff)
downloadgentoo-68f241973f415ff601304b942892dc96a9c18567.tar.gz
gentoo-68f241973f415ff601304b942892dc96a9c18567.tar.bz2
gentoo-68f241973f415ff601304b942892dc96a9c18567.zip
dev-python/cftime: Bump to 1.6.4_p1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cftime')
-rw-r--r--dev-python/cftime/Manifest1
-rw-r--r--dev-python/cftime/cftime-1.6.4_p1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/cftime/Manifest b/dev-python/cftime/Manifest
index c350d91bcc6f..bca2a39a91b1 100644
--- a/dev-python/cftime/Manifest
+++ b/dev-python/cftime/Manifest
@@ -1 +1,2 @@
+DIST cftime-1.6.4.post1.tar.gz 54631 BLAKE2B 5fee4a70d593b76e6d917f964ac99f7313d2c79d554151be7e8374eb8390b2fd712c14f9ed7e4ebf4397a534e3d9c902758c151d06bf2389d7f5dee72792711e SHA512 1250a34e37bd653f502a461df11bd3d34aaf0372708b2c2565037b90183c76ce5b8b1ce61264ba1a819fff05fc53f8759b42620e66da40aa79dcb25caa6cb020
DIST cftime-1.6.4.tar.gz 54615 BLAKE2B a986c3bc5eb1d45a31fcad849f621c9299f72c305fe29d75b50ff8c8be97e71032f306d1d33d29d4b58e8a31adfb23c552ed990026ea30ee4f34f3e2b4698dec SHA512 8b27859680a9fb1d3acc3bd95faab040b4571de40a07b327ea161a0dfad022a6c27008f74a4070c314c05e7237fd8574075e0c92d863dbcc81cd7f7d34e01399
diff --git a/dev-python/cftime/cftime-1.6.4_p1.ebuild b/dev-python/cftime/cftime-1.6.4_p1.ebuild
new file mode 100644
index 000000000000..feabb61db443
--- /dev/null
+++ b/dev-python/cftime/cftime-1.6.4_p1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Time-handling functionality from netcdf4-python"
+HOMEPAGE="
+ https://github.com/Unidata/cftime/
+ https://pypi.org/project/cftime/
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~s390 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.26.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=dev-python/cython-0.29.20[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -e "/--cov/d" -i setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}