summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 11:43:16 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitbf0b345873e825f7ad2e4867ee03d16de4434330 (patch)
tree9ccb2df26e9a6afcec313f6686e923c9447cab15 /dev-python/characteristic
parentdev-python/jinja: Add python3.5 support (diff)
downloadgentoo-bf0b345873e825f7ad2e4867ee03d16de4434330.tar.gz
gentoo-bf0b345873e825f7ad2e4867ee03d16de4434330.tar.bz2
gentoo-bf0b345873e825f7ad2e4867ee03d16de4434330.zip
dev-python/characteristic: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/characteristic')
-rw-r--r--dev-python/characteristic/characteristic-14.3.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/characteristic/characteristic-14.3.0-r1.ebuild b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
new file mode 100644
index 000000000000..32358868a9dd
--- /dev/null
+++ b/dev-python/characteristic/characteristic-14.3.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python attributes without the boilerplate"
+HOMEPAGE="https://characteristic.readthedocs.org/ https://github.com/hynek/characteristic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}