summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-25 06:48:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-25 07:11:37 +0200
commitd3aa25ecd030e441a2ac6de9e6ebfbadbc02173d (patch)
tree7727a0a53ab950732526c8b67bc8e726ae017e28 /dev-python/configupdater
parentdev-python/ini2toml: Bump to 0.11 (diff)
downloadgentoo-d3aa25ecd030e441a2ac6de9e6ebfbadbc02173d.tar.gz
gentoo-d3aa25ecd030e441a2ac6de9e6ebfbadbc02173d.tar.bz2
gentoo-d3aa25ecd030e441a2ac6de9e6ebfbadbc02173d.zip
dev-python/configupdater: New package, v3.1
A new test dep for dev-python/ini2toml. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/configupdater')
-rw-r--r--dev-python/configupdater/Manifest1
-rw-r--r--dev-python/configupdater/configupdater-3.1.ebuild32
-rw-r--r--dev-python/configupdater/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/configupdater/Manifest b/dev-python/configupdater/Manifest
new file mode 100644
index 000000000000..be50b3831097
--- /dev/null
+++ b/dev-python/configupdater/Manifest
@@ -0,0 +1 @@
+DIST configupdater-3.1.gh.tar.gz 138671 BLAKE2B 48e349780e11ca26b4b15b44aa298058840cfcea47fc7b2e555f3ca743de1956a15255bfea2c5f96624e02e399bed99ae45f3422ab1660b8ae83087ddf6117e1 SHA512 89685a93f3bec907184d818b5adea4f87967df313fe4e4216aeef2c227fdf0b0f98757ec27da7f43adff6e2ee37020dd57b98569d5811c9dc7c3201852b27432
diff --git a/dev-python/configupdater/configupdater-3.1.ebuild b/dev-python/configupdater/configupdater-3.1.ebuild
new file mode 100644
index 000000000000..bb6d09e8a58f
--- /dev/null
+++ b/dev-python/configupdater/configupdater-3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser like ConfigParser but for updating configuration files"
+HOMEPAGE="
+ https://github.com/pyscaffold/configupdater/
+ https://pypi.org/project/ConfigUpdater/
+"
+SRC_URI="
+ https://github.com/pyscaffold/configupdater/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 PYTHON"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+src_prepare() {
+ distutils-r1_src_prepare
+ sed -i -e '/--cov/d' setup.cfg || die
+}
diff --git a/dev-python/configupdater/metadata.xml b/dev-python/configupdater/metadata.xml
new file mode 100644
index 000000000000..9fbb7c1b9718
--- /dev/null
+++ b/dev-python/configupdater/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pyscaffold/configupdater</remote-id>
+ <remote-id type="pypi">ConfigUpdater</remote-id>
+ </upstream>
+</pkgmetadata>