summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-20 06:22:15 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-20 06:45:45 +0200
commit8df117d7ca62ad716e99a0c6c6e51b542832f3b3 (patch)
tree9a8f4f4e8996bcc708cb37360b23cedaadfd17c2 /dev-python/django-cors-headers
parentdev-python/filelock: Bump to 3.15.3 (diff)
downloadgentoo-8df117d7ca62ad716e99a0c6c6e51b542832f3b3.tar.gz
gentoo-8df117d7ca62ad716e99a0c6c6e51b542832f3b3.tar.bz2
gentoo-8df117d7ca62ad716e99a0c6c6e51b542832f3b3.zip
dev-python/django-cors-headers: Bump to 4.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-cors-headers')
-rw-r--r--dev-python/django-cors-headers/Manifest1
-rw-r--r--dev-python/django-cors-headers/django-cors-headers-4.4.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/django-cors-headers/Manifest b/dev-python/django-cors-headers/Manifest
index 9365cb982008..b8dced26cef3 100644
--- a/dev-python/django-cors-headers/Manifest
+++ b/dev-python/django-cors-headers/Manifest
@@ -1 +1,2 @@
DIST django-cors-headers-4.3.1.gh.tar.gz 30478 BLAKE2B b07b08df239350fa1f2036130e434c1e543122c5a8867887819e5632a40e28c8ea3b18db87ad447b54c6b6ad87904504edf2bcb7de8bf619247d6ab9f703102d SHA512 cfabc3631774337fcb634e36e43af23dfd3e3c0316ff6e367b07a05d7f96dff77e3c0d0a5539f916e9169132b44944bbb79ba92705e36f54284cc1c9eb3c30d8
+DIST django-cors-headers-4.4.0.gh.tar.gz 31028 BLAKE2B 065ac5a96c3871e8dc0eff48ef54efeb57d60a2a1588b69345f116600fe31ce7b0532ff38ca554eb5a6cff338f10e557c8876486a10db158c24a6097c44d7288 SHA512 7a380512a62420d4b6b47d43fd5d5ced1579db61fc538b4b22665e14a71298a1b1f9ebe93f808245b756d18c494177ef9ecaa01ae8d86f90a2bbf9db9b1997d7
diff --git a/dev-python/django-cors-headers/django-cors-headers-4.4.0.ebuild b/dev-python/django-cors-headers/django-cors-headers-4.4.0.ebuild
new file mode 100644
index 000000000000..cd44aca52d1b
--- /dev/null
+++ b/dev-python/django-cors-headers/django-cors-headers-4.4.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Django App that adds CORS (Cross-Origin Resource Sharing) headers to responses"
+HOMEPAGE="
+ https://github.com/adamchainz/django-cors-headers/
+ https://pypi.org/project/django-cors-headers/
+"
+SRC_URI="
+ https://github.com/adamchainz/django-cors-headers/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/asgiref-3.6[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest