summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-18 04:25:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-18 04:37:05 +0200
commit59ec7dd975404c1c013e19e097696ae3e8d090c1 (patch)
treee3bdf77160e651004654664f220b671661ce3c27 /dev-python/django-otp
parentdev-python/pytest-codeblocks: Bump to 0.17.0 (diff)
downloadgentoo-59ec7dd975404c1c013e19e097696ae3e8d090c1.tar.gz
gentoo-59ec7dd975404c1c013e19e097696ae3e8d090c1.tar.bz2
gentoo-59ec7dd975404c1c013e19e097696ae3e8d090c1.zip
dev-python/django-otp: Bump to 1.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-otp')
-rw-r--r--dev-python/django-otp/Manifest1
-rw-r--r--dev-python/django-otp/django-otp-1.2.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/django-otp/Manifest b/dev-python/django-otp/Manifest
index 86bf5334f14d..d2a58379bc08 100644
--- a/dev-python/django-otp/Manifest
+++ b/dev-python/django-otp/Manifest
@@ -1 +1,2 @@
DIST django_otp-1.2.2.tar.gz 66391 BLAKE2B f66472ec2e3842ebc634edd8f689d1de51738381fd86c4af0859dee2f1bcf407b1c952c795203f9c742a95633ee14ce9253dcc1ffd7988c960e26b23a1ec5dfe SHA512 e8608f0a3b0aeaa82e509f034f69131eb1015124ecf84b734a5be58f62c309eee506b12fffe2aeb4b707e70c612413d1458bc64533102508c55255035432eb1f
+DIST django_otp-1.2.3.tar.gz 66417 BLAKE2B 30fa8efe11b061fc6332de18f4e86181c180123c7c46ae4f9102e59a587ec39f9922db7e8c7f1c3b7a19817a336969b4aa82e2dca64447736ec244ec0098f505 SHA512 fd881cc7b44350bcfa95d243dab08465b0251b5d45fde0766532b281fce676d0afbfb35b671c1a787579374049d43e44091af77bfbb7ac6da29713dcc3cfc98f
diff --git a/dev-python/django-otp/django-otp-1.2.3.ebuild b/dev-python/django-otp/django-otp-1.2.3.ebuild
new file mode 100644
index 000000000000..a7fd6fe4a416
--- /dev/null
+++ b/dev-python/django-otp/django-otp-1.2.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django framework adding two-factor authentication using one-time passwords"
+HOMEPAGE="
+ https://github.com/django-otp/django-otp/
+ https://pypi.org/project/django-otp/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ local -x PYTHONPATH=test:${PYTHONPATH}
+ local -x DJANGO_SETTINGS_MODULE=test_project.settings
+ "${EPYTHON}" -m django test -v 2 django_otp ||
+ die "Tests fail with ${EPYTHON}"
+}