summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-10-30 11:22:48 +0100
committerFabian Groffen <grobian@gentoo.org>2017-10-30 11:22:48 +0100
commit4bf0b82a360a647f0ca63045f086b2613a1d9ac8 (patch)
tree9888e902d16b24b37323be5cd599f39ae0c52606 /dev-python/dulwich
parentmedia-gfx/imagemagick: stable 6.9.9.20 for hppa, bug #635666 (diff)
downloadgentoo-4bf0b82a360a647f0ca63045f086b2613a1d9ac8.tar.gz
gentoo-4bf0b82a360a647f0ca63045f086b2613a1d9ac8.tar.bz2
gentoo-4bf0b82a360a647f0ca63045f086b2613a1d9ac8.zip
dev-python/dulwich: version bump, bug #635856
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest2
-rw-r--r--dev-python/dulwich/dulwich-0.18.5.ebuild50
-rw-r--r--dev-python/dulwich/dulwich-0.9.9.ebuild43
3 files changed, 51 insertions, 44 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index b5cc5489a3ff..971ba685a7fa 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,3 @@
DIST dulwich-0.17.3.tar.gz 311704 SHA256 0c3eccac93823e172b05d57aaeab3d6f03c6c0f1867613606d1909a3ab4100ca SHA512 1cc7950d53b8d8bb98f9206e1ced74857f756d4355813ddb2463cef855419ac57ae411e422e500b736c3e577f71da70d675d1f172140d4cc0645d3d5ab9e6e32 WHIRLPOOL c094224fd8c8f135114a7a91f4bbf509f7c28c24d3cdf8e6af25f8ccbbab6fb1bbe39fae1594429844746f6e006f4a63b9536fa84ecd3d617c6c6f5a2a2d5fe2
DIST dulwich-0.18.3.tar.gz 328891 SHA256 d34c2628f89a5ac632fa462b2edd5afcfbf512793cfa14452d4c52f786962a8a SHA512 c89ae096407b59b37c2c36e7a429f2162950a0ee93f0ac619ea74c7ce48231ad9af097203dc8d9e2cd59bf1962f9c13325de61e9988c402fd3e212aacd910898 WHIRLPOOL 6d7aa5dd97fbc61d4248dc44626375ff465b132ae7c4ef8b60a473f138e53beb909e23e7a2fa2307a8bf44a8df52ff87f8958a41830ba16783918494d1668e01
-DIST dulwich-0.9.9.tar.gz 270127 SHA256 084e762c8d4d0c0002823249db57b8e735c99c409dacc2849565dd3c0c288496 SHA512 5039e8e80c51b8ee0df2ba0805fa63d9b476a05c86b6bd9eaf9348ac03a83f0f1208e259ae6bcf40fb2c94ffb57c9b45bff852e367b8bee95c10e672d3dc19d5 WHIRLPOOL 2a79d25f1233d9a6a242d064af179486810555eb3c9803c336ae152095318a32eb8588779cb07f84b073a05bf7f083ba3b3d4c8d2b4f8929b2aa3d01c29a0a01
+DIST dulwich-0.18.5.tar.gz 330097 SHA256 838bac318fd0ed79e0eedb6cfd53b6424dc618fec6b99dc959881b12da7bd6e0 SHA512 4ba0f70ebddf4c7f4e71721812e228f820226d4ea42bda4d5f06a0720a029d4dddb800cfc05b2610525922c5fcef1020edd1485105706d9ef3fcf810e6381035 WHIRLPOOL 7ab826c3d294ca17500de5beeb18e70cd912d468361e9972800ffd54768751d84c9f26e99871e2ba760a91d78397db786f0db7a2c3d16f4c301f8961138b3566
diff --git a/dev-python/dulwich/dulwich-0.18.5.ebuild b/dev-python/dulwich/dulwich-0.18.5.ebuild
new file mode 100644
index 000000000000..2a3bf41392d3
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.18.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# One test sometimes fails
+# https://github.com/jelmer/dulwich/issues/541
+PATCHES=( "${FILESDIR}/${PN}-0.18.3-skip-failing-test.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ emake check
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/examples"
+ doins -r examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/dulwich/dulwich-0.9.9.ebuild b/dev-python/dulwich/dulwich-0.9.9.ebuild
deleted file mode 100644
index 6aa147ef4093..000000000000
--- a/dev-python/dulwich/dulwich-0.9.9.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.python.org/pypi/dulwich"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/gevent[$(python_gen_usedep python2_7)] )"
-RDEPEND=""
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- # https://github.com/jelmer/dulwich/issues/196
- if [[ "${EPYTHON}" == pypy ]]; then
- "${PYTHON}" -m unittest dulwich.tests.test_suite || die "Tests failed under pypy"
- else
- emake check
- fi
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}