summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-24 18:28:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-24 19:38:44 +0100
commit7e76bccc3483ca9981b03b533dec8fe0036662c1 (patch)
tree8f29f4f431a1df3f2b729545c3acdb04200f83d8 /dev-python/fakeredis
parentdev-python/construct: Bump to 2.10.631 (diff)
downloadgentoo-7e76bccc3483ca9981b03b533dec8fe0036662c1.tar.gz
gentoo-7e76bccc3483ca9981b03b533dec8fe0036662c1.tar.bz2
gentoo-7e76bccc3483ca9981b03b533dec8fe0036662c1.zip
dev-python/fakeredis: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-1.5.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index da5d1c5cd15a..d7e1c8f036c8 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-1.4.5.gh.tar.gz 66197 BLAKE2B f0f36d1e209673f7722849e835c2a33fac9f7e8bfb1294ecf2e69478295f14af514d0fc4a5732a20ce099333b136d682591fef031ce90d6262fa8c9025cbfa2e SHA512 e16ae5c5947a924b0c9c40ae68efebad5cccea9f88d1b5c3f1677e1ccb8c1fa75dbafc9b413c2359b774f3043c387ff91ecd4e2e21204036883175944338d59b
+DIST fakeredis-1.5.0.gh.tar.gz 66371 BLAKE2B da9a961b9e163ba8221193c9c353f17bd23a710bd105b4fc6b9249a857828ece0b3551e3890818b0519f96aa9691166658332c25b796b22827f0951d3f50cebf SHA512 5bd4965c36abada4b937b635318d58e88ba76d30ff577b0f9b9134a94a3407a8c0e92d953e6b5299cabfe11ebe5a785e9d75406e8a07a4257674be64f6b8cffb
diff --git a/dev-python/fakeredis/fakeredis-1.5.0.ebuild b/dev-python/fakeredis/fakeredis-1.5.0.ebuild
new file mode 100644
index 000000000000..7c66ea7651cb
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-1.5.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/jamesls/fakeredis/
+ https://pypi.org/project/fakeredis/"
+SRC_URI="
+ https://github.com/jamesls/fakeredis/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local excludes=(
+ # tests for use with aioredis, not packaged in ::gentoo
+ --ignore test/test_aioredis.py
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+
+ epytest "${excludes[@]}"
+}