summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-25 05:48:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-25 05:48:31 +0200
commitfd6048918431a31998ad385a0e5fd75996530034 (patch)
tree365712be6cc7e9b7183593eb278894178f7fb635 /dev-python/fakeredis
parentdev-python/werkzeug: Bump to 3.0.5 (diff)
downloadgentoo-fd6048918431a31998ad385a0e5fd75996530034.tar.gz
gentoo-fd6048918431a31998ad385a0e5fd75996530034.tar.bz2
gentoo-fd6048918431a31998ad385a0e5fd75996530034.zip
dev-python/fakeredis: Bump to 2.26.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fakeredis')
-rw-r--r--dev-python/fakeredis/Manifest1
-rw-r--r--dev-python/fakeredis/fakeredis-2.26.0.ebuild97
2 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/fakeredis/Manifest b/dev-python/fakeredis/Manifest
index e95dacc85231..f8067aecb5bc 100644
--- a/dev-python/fakeredis/Manifest
+++ b/dev-python/fakeredis/Manifest
@@ -1 +1,2 @@
DIST fakeredis-2.25.1.tar.gz 149463 BLAKE2B a96c54cbbb221cfcf3d2a096fce90807a92f6cbc6ec474c3705058f47db8d37f7f957321c0ea631a116269068618fcbb1e9168fd17404a49611e37c423c2a08c SHA512 999113bb7c2a15ef16d51dc8c8eea906786eaaa102ed8d9d639423852a070c837504e8926bfa32fe7f4b2481d9e8fb0c588c3fe29347642e8984b46f0b2783ca
+DIST fakeredis-2.26.0.tar.gz 150240 BLAKE2B a0813dd0e4bf2bb788fdef3651f9419b5e0dcaecc2b8ebcd3f3774f59b498c90aedbd65aba7779d1eb16580c32e7625e481658f162cb01c3e0680562280b0675 SHA512 708256e08722ea61b8677d1d7299364582e279cd5d69b9551b037968652e361a93832696fd31c6255dae5d5ab2d6cda0b0f4c05c398bb4434b8d846f1feeab9b
diff --git a/dev-python/fakeredis/fakeredis-2.26.0.ebuild b/dev-python/fakeredis/fakeredis-2.26.0.ebuild
new file mode 100644
index 000000000000..7dfb54aa0658
--- /dev/null
+++ b/dev-python/fakeredis/fakeredis-2.26.0.ebuild
@@ -0,0 +1,97 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fake implementation of redis API for testing purposes"
+HOMEPAGE="
+ https://github.com/cunla/fakeredis-py/
+ https://pypi.org/project/fakeredis/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.3[${PYTHON_USEDEP}]
+ <dev-python/sortedcontainers-3[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # https://github.com/cunla/fakeredis-py/issues/320
+ sed -i -e '/LICENSE/d' pyproject.toml || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # also lupa
+ test/test_aioredis2.py::test_failed_script_error
+ # TODO
+ "test/test_fakeredis.py::test_set_get_nx[StrictRedis]"
+ "test/test_fakeredis.py::test_lpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_rpop_count[StrictRedis]"
+ "test/test_fakeredis.py::test_zadd_minus_zero[StrictRedis]"
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_channels[StrictRedis]"
+ test/test_mixins/test_set_commands.py::test_smismember_wrong_type
+ # new redis-server?
+ "test/test_mixins/test_pubsub_commands.py::test_pubsub_shardnumsub[StrictRedis]"
+ # json ext
+ test/test_json/test_json.py
+ test/test_json/test_json_arr_commands.py
+ # tdigest ext?
+ 'test/test_mixins/test_server_commands.py::test_command[FakeStrictRedis]'
+ )
+ local EPYTEST_IGNORE=(
+ # these tests fail a lot...
+ test/test_hypothesis.py
+ )
+ local args=(
+ # tests requiring lupa (lua support)
+ -k 'not test_eval and not test_lua and not test_script'
+ )
+ # Note: this package is not xdist-friendly
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -p pytest_mock "${args[@]}"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6390
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}