summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 10:09:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 10:16:15 +0100
commit638402a62a620600b5061b7ec9c4efbe42586b7d (patch)
tree8a66b51901a9b757db90494e732ea69cb0c318da /dev-python/flask-restful
parentdev-python/flask-paginate: Remove redundant versions (diff)
downloadgentoo-638402a62a620600b5061b7ec9c4efbe42586b7d.tar.gz
gentoo-638402a62a620600b5061b7ec9c4efbe42586b7d.tar.bz2
gentoo-638402a62a620600b5061b7ec9c4efbe42586b7d.zip
dev-python/flask-restful: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-restful')
-rw-r--r--dev-python/flask-restful/Manifest2
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild51
-rw-r--r--dev-python/flask-restful/flask-restful-0.3.6.ebuild51
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/flask-restful/Manifest b/dev-python/flask-restful/Manifest
index 3e580322b490..91f525f45a67 100644
--- a/dev-python/flask-restful/Manifest
+++ b/dev-python/flask-restful/Manifest
@@ -1,3 +1 @@
-DIST flask-restful-0.3.5.tar.gz 113214 BLAKE2B 0acf4d0449c55861b801a990bc3220d98e47ebeacb3c5b6452774992ae19ada97e31922e440a8a533bb1be68d4476e2654a8ca224b2369fd7733cc4c0da465c4 SHA512 a541e6739644b4db6ae97cf529bfc43f3136c97fc19a8538277d1f9be033b7c6dc3e39e1c4b2f313e099efbe750dbdc85c67b527224df557567ecac668e5969a
-DIST flask-restful-0.3.6.tar.gz 114512 BLAKE2B f03f7ed0fd521a265b8a2293d1526273650a38f65b28933b4d90d74f7365e04650efc89a743a49ab7c9fdd59d238958bb7bc03936f44af8728a4c435d2df23be SHA512 c5136302111e6c8953e038d31b42b029744111bb916dea7ec8bd5fac2de5e17a86d30a7d04a7335cdc5da25ee13f35ad9a6d284166e11cca0c6fec96d23fd977
DIST flask-restful-0.3.7.tar.gz 114238 BLAKE2B ec960f060b3a1a36e538606d710a57e9d9fb3b1c2c1ee1874c5f7592e9ad8a9a2af4716f820f27ec1a9e55fcb0505ca711c6e045e6cb0ef8c9c64de339871710 SHA512 1d1d066dec5f39af3197b680f791d83df686602b703efe874ea0e81d7f3b65f605dbdb63f84fdd07e469c6824d52571e195ae70f58e1543b53f13a81e1cd8543
diff --git a/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild b/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
deleted file mode 100644
index 2222cc76b5b2..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.5-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
-SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc examples paging test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_compile_all() {
- cd docs || die
- emake man $(usex doc html "")
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}
diff --git a/dev-python/flask-restful/flask-restful-0.3.6.ebuild b/dev-python/flask-restful/flask-restful-0.3.6.ebuild
deleted file mode 100644
index 7fd37c917f42..000000000000
--- a/dev-python/flask-restful/flask-restful-0.3.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple framework for creating REST APIs"
-HOMEPAGE="https://flask-restful.readthedocs.io/en/latest/ https://github.com/twilio/flask-restful/"
-SRC_URI="https://github.com/twilio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples paging test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/aniso8601-0.82[${PYTHON_USEDEP}]
- >=dev-python/flask-0.8[${PYTHON_USEDEP}]
- >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- paging? ( >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/sphinx[${PYTHON_USEDEP}]
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycrypto[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- nosetests -v || die "Tests fail with ${EPYTHON}"
-}
-
-python_compile_all() {
- cd docs || die
- emake man $(usex doc html "")
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && dodoc -r examples
- local DOCS=( AUTHORS.md CHANGES.md CONTRIBUTING.md README.md )
-
- doman docs/_build/man/*
- distutils-r1_python_install_all
-}