summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-11-14 20:49:09 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-11-14 21:22:01 -0500
commit7284e197dde1fae0e2c3bdf6515e5c056236d1e5 (patch)
tree703215c19cd239a1586280055e8e617f187ac619 /dev-python/gherkin-official
parentsci-geosciences/josm-bin: Stabilize 19230 amd64, #943504 (diff)
downloadgentoo-7284e197dde1fae0e2c3bdf6515e5c056236d1e5.tar.gz
gentoo-7284e197dde1fae0e2c3bdf6515e5c056236d1e5.tar.bz2
gentoo-7284e197dde1fae0e2c3bdf6515e5c056236d1e5.zip
dev-python/gherkin-official: new package, add 30.0.3
Needed by pytest-bdd-8.0.0. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/gherkin-official')
-rw-r--r--dev-python/gherkin-official/Manifest1
-rw-r--r--dev-python/gherkin-official/gherkin-official-30.0.3.ebuild34
-rw-r--r--dev-python/gherkin-official/metadata.xml13
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/gherkin-official/Manifest b/dev-python/gherkin-official/Manifest
new file mode 100644
index 000000000000..d1b4b5251630
--- /dev/null
+++ b/dev-python/gherkin-official/Manifest
@@ -0,0 +1 @@
+DIST gherkin-30.0.3.gh.tar.gz 3858361 BLAKE2B 9955a2d48dfdbfda942c60d18108fa9abc7bc7e748f5296afb802fb05b5a3b4904b74d3cff364a0fad0b9b3d378799764c2620ccb0a84af689bc8d95c7d4fbc8 SHA512 c9d722982fe926eec57cc185043983cd2380bf6ce58e5743b53cb2b98127d3b3f8b6689c39c51c2d3697e5f40bc6f98beb4c239d601b1d7685e09f5dcaa07e00
diff --git a/dev-python/gherkin-official/gherkin-official-30.0.3.ebuild b/dev-python/gherkin-official/gherkin-official-30.0.3.ebuild
new file mode 100644
index 000000000000..4a0f1cca107a
--- /dev/null
+++ b/dev-python/gherkin-official/gherkin-official-30.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="Gherkin parser/compiler for Python"
+HOMEPAGE="https://github.com/cucumber/gherkin/"
+SRC_URI="
+ https://github.com/cucumber/gherkin/archive/refs/tags/v${PV}.tar.gz
+ -> gherkin-${PV}.gh.tar.gz
+"
+S=${WORKDIR}/gherkin-${PV}/python
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_install() {
+ distutils-r1_python_install
+
+ # dev-python/pytest-bdd tests currently fail without this
+ python_moduleinto gherkin
+ python_domodule ../gherkin-languages.json
+}
diff --git a/dev-python/gherkin-official/metadata.xml b/dev-python/gherkin-official/metadata.xml
new file mode 100644
index 000000000000..8adb581ac5ef
--- /dev/null
+++ b/dev-python/gherkin-official/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ionen@gentoo.org</email>
+ <name>Ionen Wolkens</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">cucumber/gherkin</remote-id>
+ <remote-id type="pypi">gherkin-official</remote-id>
+ </upstream>
+</pkgmetadata>