summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-16 12:07:21 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-16 12:07:21 +0300
commit7024de42af301ddb122536179a3339ed93e22bee (patch)
tree2f83993f3d42ffd524d8c6353af90dc5a0907ab2 /dev-python/google-auth-oauthlib
parentdev-python/readthedocs-sphinx-ext: add 2.1.9 (diff)
downloadgentoo-7024de42af301ddb122536179a3339ed93e22bee.tar.gz
gentoo-7024de42af301ddb122536179a3339ed93e22bee.tar.bz2
gentoo-7024de42af301ddb122536179a3339ed93e22bee.zip
dev-python/google-auth-oauthlib: add 0.5.3
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/google-auth-oauthlib')
-rw-r--r--dev-python/google-auth-oauthlib/Manifest1
-rw-r--r--dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-oauthlib/Manifest b/dev-python/google-auth-oauthlib/Manifest
index f2eb2cd41d46..172afb57e808 100644
--- a/dev-python/google-auth-oauthlib/Manifest
+++ b/dev-python/google-auth-oauthlib/Manifest
@@ -1 +1,2 @@
DIST google-auth-library-python-oauthlib-0.5.2.gh.tar.gz 53842 BLAKE2B 7adcd9f339ec9a5528308fcc0fee1cbbe96440e1bfe5c7cc9c94808668e22801b612d291a2419333888194c3224838ac40f9d0656381825bd660067470f58910 SHA512 eaf296a0e0504e8249637a8db7531c10b120f28abeeab3e1fe8f366b4279c396509188e83f8a0ec56be85063430ceb691d6d926cee33d4f166bbcc4425e538db
+DIST google-auth-library-python-oauthlib-0.5.3.gh.tar.gz 69613 BLAKE2B 74338894f35fd1cd8802ea56952561ce0e801fecb2f994b71caf3c6b62a22e8b85f8a5b40f5571b05225a565b373865377d321625aeea2dafcc0cafb89da1492 SHA512 76c855e9becd57d3cb3bb0b203ad77ef17dc04e8be8b96d17a9c1f29474a8b180edb725e835d0552c5eddbb387cc463e88b076dd6d11635e6d45798224f09188
diff --git a/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild
new file mode 100644
index 000000000000..9aa755ca297b
--- /dev/null
+++ b/dev-python/google-auth-oauthlib/google-auth-oauthlib-0.5.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=google-auth-library-python-oauthlib-${PV}
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/
+ https://pypi.org/project/google-auth-oauthlib/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-oauthlib/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/click-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-oauthlib-0.7.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest