summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-15 06:30:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-15 11:22:21 +0200
commit294259eec26a088cf4e662eb1da155d85c228ad3 (patch)
treeb2551a77ed8e9f60e7aceeca352a4627e97fd38f /dev-python/graphviz
parentdev-python/python-dateutil: Bump to 2.8.2 (diff)
downloadgentoo-294259eec26a088cf4e662eb1da155d85c228ad3.tar.gz
gentoo-294259eec26a088cf4e662eb1da155d85c228ad3.tar.bz2
gentoo-294259eec26a088cf4e662eb1da155d85c228ad3.zip
dev-python/graphviz: Bump to 0.17
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/graphviz')
-rw-r--r--dev-python/graphviz/Manifest1
-rw-r--r--dev-python/graphviz/graphviz-0.17.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/graphviz/Manifest b/dev-python/graphviz/Manifest
index 64a7ab115a0e..06ca7da83f3b 100644
--- a/dev-python/graphviz/Manifest
+++ b/dev-python/graphviz/Manifest
@@ -1 +1,2 @@
DIST graphviz-0.16.zip 193031 BLAKE2B abedbe170eaf9d3ad83f91b5ad13aa9fbda8669ac19ebbd1087aeab3f9401b0b8e6557313e04d791451ee501c75bc2843d89d1a0f789a219b0db771467b4b8bb SHA512 7896901decf712657d4cb16fad58eab8492e1476e60a32b1a7fa37ede2e9c47ed31c00b7dedcaafdee291e2cfe6b2e2affa352282665782829fd3fb2f30bdf92
+DIST graphviz-0.17.zip 193647 BLAKE2B f2f5ad728157d60c48964d2cfdc76559310af6099a9eae16279b0f9e8a41c08d02d5f255be62222c1f0808750a26e67822b5fbb930f7ada5c6a614c3607494cd SHA512 02f5ef21f9e3bf3b609f43fe0d9cb51632ea43c878055746af62fda4dd55883f6ad58f69faecb6aba552100cc835901309c8c2ec833cd74c617619fce2d49600
diff --git a/dev-python/graphviz/graphviz-0.17.ebuild b/dev-python/graphviz/graphviz-0.17.ebuild
new file mode 100644
index 000000000000..befd64b4a916
--- /dev/null
+++ b/dev-python/graphviz/graphviz-0.17.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+RDEPEND="media-gfx/graphviz"
+BDEPEND="
+ app-arch/unzip
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+ media-gfx/graphviz[gts,pdf]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e 's:--cov --cov-report=term --cov-report=html::' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}