summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 08:00:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 08:23:08 +0200
commitcac50237fe91893e0d1cb36f21ec398db5d2ec82 (patch)
tree2ecb0b22321bc4ebdea7d09de3391a329d674a30 /dev-python/gsd
parentdev-python/gsd: Remove old (diff)
downloadgentoo-cac50237fe91893e0d1cb36f21ec398db5d2ec82.tar.gz
gentoo-cac50237fe91893e0d1cb36f21ec398db5d2ec82.tar.bz2
gentoo-cac50237fe91893e0d1cb36f21ec398db5d2ec82.zip
dev-python/gsd: Bump to 3.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/gsd')
-rw-r--r--dev-python/gsd/Manifest1
-rw-r--r--dev-python/gsd/gsd-3.3.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/gsd/Manifest b/dev-python/gsd/Manifest
index c57238865b5a..491953d67415 100644
--- a/dev-python/gsd/Manifest
+++ b/dev-python/gsd/Manifest
@@ -1 +1,2 @@
DIST gsd-3.3.1.tar.gz 108613 BLAKE2B fdfc1e0e70f9b3d804ec5b7a76263b077609af811c9bb1cddf304ff46701d710fead5f103b712cd408cf3c4aa19b91e5af208d586e8a9ca81b56452e2ba32587 SHA512 84a131e4ac6baa7258ed7be5886b99fb34421e919eeaddadf658c3d0a40e2c3667b7ecee8c10a4e3b264538ebfd34c5b97090b23c72c7f9ada5c6b76985b894d
+DIST gsd-3.3.2.tar.gz 108492 BLAKE2B cc585c4de8462891fbedd5a15bbfa5c531ee31cf2082b32600098d7ef8291a7067a195338384e4c42d0f64536d3feb5dc98b5099dc2bfe0ffd328447fc54389b SHA512 1ba704e5cbee3a1b9c2f8ac1b4f6d1afb9819d66b10b069965e25ad6b30f3143cdc721be204a4c34ecd0bf2ddc7eb65a1421f754cafdcc17fac2edad4fc58911
diff --git a/dev-python/gsd/gsd-3.3.2.ebuild b/dev-python/gsd/gsd-3.3.2.ebuild
new file mode 100644
index 000000000000..a16117a836ec
--- /dev/null
+++ b/dev-python/gsd/gsd-3.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="GSD - file format specification and a library to read and write it"
+HOMEPAGE="
+ https://github.com/glotzerlab/gsd/
+ https://pypi.org/project/gsd/
+"
+SRC_URI="
+ https://github.com/glotzerlab/gsd/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-python/numpy-1.24.2[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${T}" || die
+ epytest --pyargs gsd
+}