summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-19 20:38:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-19 21:56:15 +0200
commitc4958e250ed72493784b28448712625320b7b81a (patch)
treeaf2e8143beb1ef6d373b89d1c94027b52096e5d9 /dev-python/hiredis
parentdev-python/django-crispy-forms: Bump to 2.3 (diff)
downloadgentoo-c4958e250ed72493784b28448712625320b7b81a.tar.gz
gentoo-c4958e250ed72493784b28448712625320b7b81a.tar.bz2
gentoo-c4958e250ed72493784b28448712625320b7b81a.zip
dev-python/hiredis: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hiredis')
-rw-r--r--dev-python/hiredis/Manifest1
-rw-r--r--dev-python/hiredis/files/hiredis-2.4.0-system-libs.patch33
-rw-r--r--dev-python/hiredis/hiredis-2.4.0.ebuild45
3 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/hiredis/Manifest b/dev-python/hiredis/Manifest
index 6d51028a1b45..5f97ff664c28 100644
--- a/dev-python/hiredis/Manifest
+++ b/dev-python/hiredis/Manifest
@@ -1 +1,2 @@
DIST hiredis-py-2.3.2.gh.tar.gz 19076 BLAKE2B 4a3e747765f559407b3ad84524bc1040e3a530723b5756320743fc20400bc70e867d48e71696d732a5fa5eb231199cbefb6f487d0b5ece6fc8f6c41f10f3c0d8 SHA512 1a22ab324f9675973c3dc37c55d6dd9cf43fbc161003003a73b2e1dfbb3fed7dcb1433f4fc51045a88cb2735f7c8495b93a819a0a9f6300e05b0cc85160eaace
+DIST hiredis-py-2.4.0.gh.tar.gz 19076 BLAKE2B a5b047db044801e5dabdd5bcaefb5a89cce472f45baa6a3d590b09014446695ed84baaa46bc4d8a809cc6ffa2a2e219e03b62268ee9f818ef5e9c770cd064591 SHA512 638184fff812cf2c0d0e731be98e22c37c2c07db539ce2ad1e5d45e8f399864bc49e5e26cd0b1fcdf7db9fc776a664f8541229ef00da0b597c4be4f3ab7461cf
diff --git a/dev-python/hiredis/files/hiredis-2.4.0-system-libs.patch b/dev-python/hiredis/files/hiredis-2.4.0-system-libs.patch
new file mode 100644
index 000000000000..92a14f91d200
--- /dev/null
+++ b/dev-python/hiredis/files/hiredis-2.4.0-system-libs.patch
@@ -0,0 +1,33 @@
+--- hiredis-2.2.2.orig/setup.py
++++ hiredis-2.2.2/setup.py
+@@ -18,8 +18,7 @@
+
+
+ def get_sources():
+- hiredis_sources = ("alloc", "async", "hiredis", "net", "read", "sds", "sockcompat")
+- return sorted(glob.glob("src/*.c") + ["vendor/hiredis/%s.c" % src for src in hiredis_sources])
++ return sorted(glob.glob("src/*.c"))
+
+
+ def get_linker_args():
+@@ -38,17 +37,16 @@
+
+ def get_libraries():
+ if 'win32' in sys.platform:
+- return ["ws2_32", ]
++ return ["ws2_32", "hiredis"]
+ else:
+- return []
++ return ["hiredis"]
+
+
+ ext = Extension("hiredis.hiredis",
+ sources=get_sources(),
+ extra_compile_args=get_compiler_args(),
+ extra_link_args=get_linker_args(),
+- libraries=get_libraries(),
+- include_dirs=["vendor"])
++ libraries=get_libraries())
+
+ setup(
+ name="hiredis",
diff --git a/dev-python/hiredis/hiredis-2.4.0.ebuild b/dev-python/hiredis/hiredis-2.4.0.ebuild
new file mode 100644
index 000000000000..a7183e750350
--- /dev/null
+++ b/dev-python/hiredis/hiredis-2.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=hiredis-py-${PV}
+DESCRIPTION="Python extension that wraps hiredis"
+HOMEPAGE="
+ https://github.com/redis/hiredis-py/
+ https://pypi.org/project/hiredis/
+"
+SRC_URI="
+ https://github.com/redis/hiredis-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/hiredis-1.0.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/hiredis-2.4.0-system-libs.patch
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ rm -rf hiredis || die
+ epytest
+}