summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 08:59:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 08:59:09 +0100
commitdc6053f22496b1d2985ef4b08e7b2c98451e47a6 (patch)
tree073dbd2b5d4550ea893e401ff5abcda31d0efaa9 /dev-python/httpx
parentdev-python/tekore: Remove old (diff)
downloadgentoo-dc6053f22496b1d2985ef4b08e7b2c98451e47a6.tar.gz
gentoo-dc6053f22496b1d2985ef4b08e7b2c98451e47a6.tar.bz2
gentoo-dc6053f22496b1d2985ef4b08e7b2c98451e47a6.zip
dev-python/httpx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/httpx')
-rw-r--r--dev-python/httpx/Manifest1
-rw-r--r--dev-python/httpx/httpx-0.21.3.ebuild76
2 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/httpx/Manifest b/dev-python/httpx/Manifest
index d1bb467c90b9..ae411e30ad60 100644
--- a/dev-python/httpx/Manifest
+++ b/dev-python/httpx/Manifest
@@ -1,2 +1 @@
-DIST httpx-0.21.3.tar.gz 2157078 BLAKE2B 08a9328a7350534abe646f0bf60bd15600a1cb3eb8d06578c87ed9a7d4e55efdddd2be597650cddec9f6456e89a1b159f3e23aa657f379f78157c12670cdadb0 SHA512 0a551de52954db5ed2c33d1b5c172607516031a7c86c0f235bd04f12f4cf82f63980a9f53115dac801748b0c282890b3ed4a53b2c912adbd245c10ad61dbf67e
DIST httpx-0.22.0.gh.tar.gz 2157682 BLAKE2B bb08a7c4b72478d24264c0dca5630205ff386af73294dca66dcd12b646de602ad64e308feedaabd58742cb7a9d799fa23cd2f922e685e74f8181e1b5e9f1c4ee SHA512 a7360f5355f75f07425b42d49697e480319f3fe606d4601bb6d64b870c8a8fce6fad8bd857ef422fc48e6141201307ee94876d5bc54a68557c7dc32ce8f1451b
diff --git a/dev-python/httpx/httpx-0.21.3.ebuild b/dev-python/httpx/httpx-0.21.3.ebuild
deleted file mode 100644
index 76f9b5757e4e..000000000000
--- a/dev-python/httpx/httpx-0.21.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# Docs builder mkdocs not keyworded on all these arches yet
-# DOCS_BUILDER="mkdocs"
-# DOCS_DEPEND="dev-python/mkdocs-material"
-# DOCS_AUTODOC=1
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 # docs
-
-DESCRIPTION="Fully-featured HTTP client which provides sync and async APIs"
-HOMEPAGE="https://www.python-httpx.org/"
-SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ppc ppc64 ~riscv sparc x86"
-IUSE="cli"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- dev-python/charset_normalizer[${PYTHON_USEDEP}]
- dev-python/sniffio[${PYTHON_USEDEP}]
- =dev-python/httpcore-0.14*[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.3[${PYTHON_USEDEP}]
- <dev-python/rfc3986-2[${PYTHON_USEDEP}]
- cli? (
- =dev-python/click-8*[${PYTHON_USEDEP}]
- =dev-python/pygments-2*[${PYTHON_USEDEP}]
- =dev-python/rich-10*[${PYTHON_USEDEP}]
- )
-"
-BDEPEND="
- test? (
- dev-python/brotlicffi[${PYTHON_USEDEP}]
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/h2[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-trio[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
- dev-python/uvicorn[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- if ! use cli; then
- sed -i -e '/console_scripts/d' setup.py || die
- fi
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet
- tests/client/test_proxies.py::test_async_proxy_close
- tests/client/test_proxies.py::test_sync_proxy_close
-
- # Result change in charset-normalizer-2.0.7+
- 'tests/test_decoders.py::test_text_decoder[data3-iso-8859-1]'
- 'tests/models/test_responses.py::test_response_no_charset_with_iso_8859_1_content'
- )
- local EPYTEST_IGNORE=()
-
- use cli || EPYTEST_IGNORE+=(
- tests/test_main.py
- )
-
- epytest
-}