summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-23 08:44:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-23 10:16:20 +0200
commit0066692db3df636cf4d33e4cd3b5899ba1cbc095 (patch)
treef89dc451308058252762790f4d3b1e0b5d70589b /dev-python/hvac
parentdev-python/urllib3: Bump to 1.26.7 (diff)
downloadgentoo-0066692db3df636cf4d33e4cd3b5899ba1cbc095.tar.gz
gentoo-0066692db3df636cf4d33e4cd3b5899ba1cbc095.tar.bz2
gentoo-0066692db3df636cf4d33e4cd3b5899ba1cbc095.zip
dev-python/hvac: Bump to 0.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hvac')
-rw-r--r--dev-python/hvac/Manifest1
-rw-r--r--dev-python/hvac/hvac-0.11.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/hvac/Manifest b/dev-python/hvac/Manifest
index 244badeebc49..9059557a4f61 100644
--- a/dev-python/hvac/Manifest
+++ b/dev-python/hvac/Manifest
@@ -5,3 +5,4 @@ DIST hvac-0.10.14.tar.gz 301617 BLAKE2B b3d721b245b9f7b0e8aa5404599da8f3fde3fe10
DIST hvac-0.10.8.tar.gz 290963 BLAKE2B 539e604d2c0476c3f8bd9bf9e803f2d7c6ea8671cd86ef650a7a3e615fa3461135e956726a869fa8b9c1883b70c11eaa51f28e6d07f284dbb43b51a696dd9958 SHA512 010a851c39bdc4d420343fa42aef5cd7faa073c11bf1507fc563791b8c93e85367b2081d573123acccd467881bccb9f9f33487551cac763d91ee7e5341ea5568
DIST hvac-0.10.9.tar.gz 291045 BLAKE2B 63c48b21e402a1af3f73e5b295061a2f82040cedd412fab69e8759e290a46eb67d1aa0ddaeb40c1638eefbc492441e238cbe4be114093015af6eabd99a0c0a75 SHA512 4af23583110ca4c2c9714f5234daf21ee199c2ac97cde01a220db6f5d89957b95c1e8b84904104e5a96ec39b54cea567973427a73ed7cae5806e794d37403a8d
DIST hvac-0.11.0.tar.gz 306753 BLAKE2B 0300705044f6575ffeb9fa3dc28d6ee1139b6ce84f52b89920606b603355530823a1f2ec8ac251423c5a0305f3ea1ae15933e84dddb2e09c5d7880b5c0508ec8 SHA512 47226ba5113a4df48f115d02d2fb1fa7ab8b42895d38f7fad37c84814db71a57f4e455a9b46134bb577fbded1881e6272464b9f1d1d74142dc089bde03b0eba9
+DIST hvac-0.11.1.tar.gz 308520 BLAKE2B 6111b88d3b772fb812db65fb770595980337d2d06366d2d3c334ee78dc4201039eca7d4086bde4384e8d987ba06e8a7343a638500c562024c8ff05196bab0bcd SHA512 5ae4b737d397399fb364c10220ed3ed083fbd203607fd488cc08c2a4e8633eeda447ec0713de6ad580d394e9fb287786eb83a9a6ededd8f8d2054874ea19fad5
diff --git a/dev-python/hvac/hvac-0.11.1.ebuild b/dev-python/hvac/hvac-0.11.1.ebuild
new file mode 100644
index 000000000000..18c424443e15
--- /dev/null
+++ b/dev-python/hvac/hvac-0.11.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="hashicorp vault client in python"
+HOMEPAGE="https://github.com/hvac/hvac"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hvac/hvac.git"
+else
+ SRC_URI="https://github.com/hvac/hvac/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/jwcrypto[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ dev-python/python-jwt[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/pyhcl-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.15.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local ignore=(
+ # ldap_test is not packaged.
+ tests/integration_tests/api/auth_methods/test_ldap.py
+ # https://github.com/lepture/authlib is not packaged.
+ tests/integration_tests/api/auth_methods/test_oidc.py
+ )
+
+ epytest ${ignore[@]/#/--ignore }
+}