summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-30 19:27:52 +0100
committerMichał Górny <mgorny@gentoo.org>2023-10-30 20:00:58 +0100
commit21763a2eb3de01a4b853cf58ae0c91d3ab136947 (patch)
treed5f932470617869ed898b196f3212ad65d59adc7 /dev-python/hypercorn
parentdev-python/taskgroup: New package, v0.0.0_alpha4 (diff)
downloadgentoo-21763a2eb3de01a4b853cf58ae0c91d3ab136947.tar.gz
gentoo-21763a2eb3de01a4b853cf58ae0c91d3ab136947.tar.bz2
gentoo-21763a2eb3de01a4b853cf58ae0c91d3ab136947.zip
dev-python/hypercorn: Bump to 0.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hypercorn')
-rw-r--r--dev-python/hypercorn/Manifest1
-rw-r--r--dev-python/hypercorn/hypercorn-0.15.0.ebuild49
-rw-r--r--dev-python/hypercorn/metadata.xml2
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/hypercorn/Manifest b/dev-python/hypercorn/Manifest
index 0f483ed03933..685dee3ef8ac 100644
--- a/dev-python/hypercorn/Manifest
+++ b/dev-python/hypercorn/Manifest
@@ -1 +1,2 @@
DIST hypercorn-0.14.4.gh.tar.gz 156001 BLAKE2B 262cbaba3df674b07dd5f6c15418cac18b46c2303a8ff616c8d2e968ff233d15bf616f2d3d0dbacda03f819251453be1b00cee4b98fdfaaed49f40cdcfb43119 SHA512 461b6fab72586b3bdea25ded6c0439595a8f84d5fb0b1a264f976926d9d34cb21f52bd10c84b9180d08fb05942f9fdb842343d4c6c476dcd60a26399387a2373
+DIST hypercorn-0.15.0.gh.tar.gz 156271 BLAKE2B 906b1b9c90c8150498ce6b8ac6f5de50373980381cd5ead206dd38be166b7e2ff0a1460aa08b2e4039d70b0412f2e38646836a867c623a2f0ff820f985cd79bc SHA512 a110f7e74eab99924c842715bdd9b32f0b3003eab4a4105968cf6779b69cb6e403dd8fd1b9910400994d25b9bf1a4d0956c99458bfcda70b1b8db2688859bacd
diff --git a/dev-python/hypercorn/hypercorn-0.15.0.ebuild b/dev-python/hypercorn/hypercorn-0.15.0.ebuild
new file mode 100644
index 000000000000..9a1a1dc9e096
--- /dev/null
+++ b/dev-python/hypercorn/hypercorn-0.15.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A ASGI Server based on Hyper libraries and inspired by Gunicorn"
+HOMEPAGE="
+ https://github.com/pgjones/hypercorn/
+ https://pypi.org/project/Hypercorn/
+"
+SRC_URI="
+ https://github.com/pgjones/hypercorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/exceptiongroup-1.1.0[${PYTHON_USEDEP}]
+ dev-python/h11[${PYTHON_USEDEP}]
+ >=dev-python/h2-3.1.0[${PYTHON_USEDEP}]
+ dev-python/priority[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/taskgroup[${PYTHON_USEDEP}]
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+ >=dev-python/wsproto-0.14.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-trio[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--no-cov-on-fail::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/hypercorn/metadata.xml b/dev-python/hypercorn/metadata.xml
index 1d8855d3b9ff..aef6884c023c 100644
--- a/dev-python/hypercorn/metadata.xml
+++ b/dev-python/hypercorn/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="pypi">hypercorn</remote-id>
+ <remote-id type="pypi">Hypercorn</remote-id>
<remote-id type="github">pgjones/hypercorn</remote-id>
</upstream>
</pkgmetadata>