summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-08 10:13:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-08 10:29:54 +0100
commit39391ccf7435674d3066dfaa18662d7886f9c906 (patch)
tree7c1b2fec3961975ddd1c7e49ac66e5080365cdc8 /dev-python/hyperlink
parentdev-python/zope-testing: Bump to 4.9 (diff)
downloadgentoo-39391ccf7435674d3066dfaa18662d7886f9c906.tar.gz
gentoo-39391ccf7435674d3066dfaa18662d7886f9c906.tar.bz2
gentoo-39391ccf7435674d3066dfaa18662d7886f9c906.zip
dev-python/hyperlink: Bump to 21.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/hyperlink')
-rw-r--r--dev-python/hyperlink/Manifest1
-rw-r--r--dev-python/hyperlink/hyperlink-21.0.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/hyperlink/Manifest b/dev-python/hyperlink/Manifest
index 94926bbd5d4b..e528cc8bc8d5 100644
--- a/dev-python/hyperlink/Manifest
+++ b/dev-python/hyperlink/Manifest
@@ -1 +1,2 @@
DIST hyperlink-20.0.1.tar.gz 140291 BLAKE2B ee8c741d4cb87e4a577e1c9a45614f5f47e086f27b60a75897b66684ab5927da73ccaba47b16b770f0277a52351cc732cf74762e29c83644c220ed59c67a18d0 SHA512 f935c09d35baf8a8a3c8d4dc6aaf64135d13dda4636187f5d47f3fe4de675498efa29cd93d802c0912db2fa371d0e58213767b1c3c42e5a14bb837ea96a72193
+DIST hyperlink-21.0.0.tar.gz 140743 BLAKE2B d432692172dc5cbb4f7cc1dbbfaf87871f0d9b2519334d112841abf8d958232516249472611e986b20e6fd298f5013db38f214fa332e1b121bd80a420b4cc614 SHA512 9e0e9273dde1b0a41329a74fbb26c4f327b87f387ee64b9a2ab641ca5cc8b9ea0516884415e9adf1d4880ae9c053a5cba2c550fc508bb56fddb44a543d5da860
diff --git a/dev-python/hyperlink/hyperlink-21.0.0.ebuild b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
new file mode 100644
index 000000000000..48f99bd74f08
--- /dev/null
+++ b/dev-python/hyperlink/hyperlink-21.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A featureful, correct URL for Python"
+HOMEPAGE="https://github.com/python-hyper/hyperlink https://pypi.org/project/hyperlink/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/idna[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_test() {
+ # suppresses hypothesis health checks
+ local -x CI=1
+ distutils-r1_src_test
+}