summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-13 17:10:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-13 17:47:13 +0200
commitbef5fe98a9357c01615a4b5fec6f6b455158d951 (patch)
treef0d2c788b316c8b06d8bf0fe0f05a4325bca495b /dev-python/imageio-ffmpeg
parentdev-python/jupyterlab-server: Bump to 2.25.0 (diff)
downloadgentoo-bef5fe98a9357c01615a4b5fec6f6b455158d951.tar.gz
gentoo-bef5fe98a9357c01615a4b5fec6f6b455158d951.tar.bz2
gentoo-bef5fe98a9357c01615a4b5fec6f6b455158d951.zip
dev-python/imageio-ffmpeg: Bump to 0.4.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio-ffmpeg')
-rw-r--r--dev-python/imageio-ffmpeg/Manifest1
-rw-r--r--dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.9.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/imageio-ffmpeg/Manifest b/dev-python/imageio-ffmpeg/Manifest
index 001645b4d617..e63e7f0825f6 100644
--- a/dev-python/imageio-ffmpeg/Manifest
+++ b/dev-python/imageio-ffmpeg/Manifest
@@ -1 +1,2 @@
DIST imageio-ffmpeg-0.4.8.gh.tar.gz 27124 BLAKE2B 84ba7cbb46feae7e95b9d6f61e9b3289a753da7d78ad2848b593969c7f2a6f9e36307ca07a4b03f672fe8f61c697dcbf2dc236a2545b9ca9547fa6f174c96220 SHA512 aa6179d8c8cdbb49a60bea5ad570c6343d5e6b5a2678e88bacc484916ff806311c121143342f039ba9d41c8ac46ffbfe0adefe298e5eba0052d72c6e1707c4a6
+DIST imageio-ffmpeg-0.4.9.gh.tar.gz 27344 BLAKE2B f9bf6421859f8b17aee5300613a14de9883436aaa724b61b8068498f533cc24ab4c8372a6de6ce4ab49218abb84af8a35e29e1ccbe9c913fcdcf2db159f13a92 SHA512 ebf63b9ac9c733d4c12d3aa4c6a9e81dd0128795a040e65df03bfae00e3562a3976eaa2f4058562bbddc3f8d63d6bf2a38133de4d2ddb0d2dc62ffab2449e143
diff --git a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.9.ebuild b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.9.ebuild
new file mode 100644
index 000000000000..caabdf39b65d
--- /dev/null
+++ b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.4.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFMPEG wrapper for Python"
+HOMEPAGE="
+ https://github.com/imageio/imageio-ffmpeg/
+ https://pypi.org/project/imageio-ffmpeg/
+"
+SRC_URI="
+ https://github.com/imageio/imageio-ffmpeg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+# ffmpeg is used as an executable during runtime
+RDEPEND="
+ media-video/ffmpeg:*
+"
+
+distutils_enable_tests pytest