summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:14:07 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:14:07 +0100
commit6fc86c5a052df84e454d0e0a34196d8db864a546 (patch)
tree222f1e06e3646ad05bbcd27c5651211bffc1fafe /dev-python/incremental
parentdev-python/s3transfer: Stabilize 0.3.4 ALLARCHES, #773865 (diff)
downloadgentoo-6fc86c5a052df84e454d0e0a34196d8db864a546.tar.gz
gentoo-6fc86c5a052df84e454d0e0a34196d8db864a546.tar.bz2
gentoo-6fc86c5a052df84e454d0e0a34196d8db864a546.zip
dev-python/incremental: Bump to 21.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/incremental')
-rw-r--r--dev-python/incremental/Manifest1
-rw-r--r--dev-python/incremental/incremental-21.3.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/incremental/Manifest b/dev-python/incremental/Manifest
index bdcef50a3936..17e5cac186c7 100644
--- a/dev-python/incremental/Manifest
+++ b/dev-python/incremental/Manifest
@@ -1 +1,2 @@
DIST incremental-17.5.0.tar.gz 15527 BLAKE2B a967ba891b69e91768db213a9692da10eb9987bf962bdbc3b6fe70e337322686d58901878b72934a5abc8d9b0c9884d6e03de5b8912067f07b7562427bcba38a SHA512 91443205f7c92ec8f6502f38379c5ac2fe441435ff9490af01e5420d6bb05bb1c666dd612fc45204199a34afd533fd3de1390ca482bb554dfec7d3a22958a4bc
+DIST incremental-21.3.0.tar.gz 17058 BLAKE2B a6c49d15eb73abbab129e675d937e795a47aca10f74a8d5fc80ebf6575ca996cc7dc16aac9ca02c7a206cf8f59b239f3fc04fc00b28827d0a3c76a88189dabf7 SHA512 b8b50151cd2467e552d9268decadbb839b047cf58a450b72e0437ffc5f9af7d78c20a24193c0668cf48dd6264b852d9cee68e59529018e0ca07825e0c185d1e8
diff --git a/dev-python/incremental/incremental-21.3.0.ebuild b/dev-python/incremental/incremental-21.3.0.ebuild
new file mode 100644
index 000000000000..cb1d012c7a34
--- /dev/null
+++ b/dev-python/incremental/incremental-21.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+# TODO: revert to rdepend once this has been merged:
+# https://github.com/twisted/incremental/pull/59
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Incremental is a small library that versions your Python projects"
+HOMEPAGE="https://github.com/twisted/incremental https://pypi.org/project/incremental/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"