summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-02 07:02:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-02 08:58:36 +0200
commitf1498b508edb607a6bc1b3d466e68fe51330e7c6 (patch)
tree38f86b26e61b771c48ec035a7895e79bc97dbaea /dev-python/inflect
parentdev-java/bcprov: drop 1.74 (diff)
downloadgentoo-f1498b508edb607a6bc1b3d466e68fe51330e7c6.tar.gz
gentoo-f1498b508edb607a6bc1b3d466e68fe51330e7c6.tar.bz2
gentoo-f1498b508edb607a6bc1b3d466e68fe51330e7c6.zip
dev-python/inflect: Bump to 7.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/inflect')
-rw-r--r--dev-python/inflect/Manifest1
-rw-r--r--dev-python/inflect/inflect-7.3.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/inflect/Manifest b/dev-python/inflect/Manifest
index 24c2249b57d8..7c9aaa33deb0 100644
--- a/dev-python/inflect/Manifest
+++ b/dev-python/inflect/Manifest
@@ -1,2 +1,3 @@
DIST inflect-7.2.1.tar.gz 71580 BLAKE2B f6256388768a850a16e79f5c59cc21bab94c65733aa4502c813e7c32c850eecf80d2148e9cb396b6fb3198004b79dc1c6dea9dbef29d5cd4e3acff25728deec3 SHA512 b994b1cb486f318f54fe73e159ffb41c637298c651e3b2ed0899659add450cd47f168e7ba242fc70dd1c177e622850409485c1671e5b89eb1f2b554d315bdf00
DIST inflect-7.3.0.tar.gz 71925 BLAKE2B 24d9cd8bc43e53b755364867f0754cc9b9b311cd409f3ba6f835d9bf98f9d46660b61bcb00e397993dd7b07b40267decf22d64a29caa68ee385e61c57d1355d4 SHA512 03ea7ad09c56a66c91ae0ad376f9203368e480e26a5f161290ae40de618372654d9e29e74c9bc86e311a4e4d96230e3ca7a5ca438e380ea49818bf1157fd8b0e
+DIST inflect-7.3.1.tar.gz 71980 BLAKE2B efb1224ec0514403db5db7cc572335a7f3dab09e7fe57559df736fee4598782c12fc9ae1d3ade89b41acc492996c7a93f04eff86c712b1c3f98f9404694f643c SHA512 562107d500ee488a35d809e4b7888af31fb90d7b07b9f6c328f66d8723a171227e639e0cbf43cb9610227faff6690a8af7205bc509f6764c9e22e9160f7ba5e1
diff --git a/dev-python/inflect/inflect-7.3.1.ebuild b/dev-python/inflect/inflect-7.3.1.ebuild
new file mode 100644
index 000000000000..d1cdcca00005
--- /dev/null
+++ b/dev-python/inflect/inflect-7.3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Correctly inflect words and numbers"
+HOMEPAGE="
+ https://pypi.org/project/inflect/
+ https://github.com/jaraco/inflect/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-python/typeguard-4.0.1[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-3.4.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest