summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-15 21:50:07 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-15 21:50:07 +0300
commit720fc1edbc24ec9cf6ca994ba6b3af5f1ca078b2 (patch)
treeab2c84532ef2f16a8a4a14f612c8e590a376ef44 /dev-python/ipywidgets
parentdev-python/ipywidgets: Stabilize 7.7.0 ALLARCHES, #838616 (diff)
downloadgentoo-720fc1edbc24ec9cf6ca994ba6b3af5f1ca078b2.tar.gz
gentoo-720fc1edbc24ec9cf6ca994ba6b3af5f1ca078b2.tar.bz2
gentoo-720fc1edbc24ec9cf6ca994ba6b3af5f1ca078b2.zip
dev-python/ipywidgets: drop 7.6.5-r2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ipywidgets')
-rw-r--r--dev-python/ipywidgets/Manifest1
-rw-r--r--dev-python/ipywidgets/files/ipywidgets-7.6.3-py310.patch37
-rw-r--r--dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild39
3 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/ipywidgets/Manifest b/dev-python/ipywidgets/Manifest
index 3cce861b413e..832122d805b3 100644
--- a/dev-python/ipywidgets/Manifest
+++ b/dev-python/ipywidgets/Manifest
@@ -1,2 +1 @@
-DIST ipywidgets-7.6.5.tar.gz 4072535 BLAKE2B bc2347863af42254e740454e1d91ca8b7fc03de9dc6a2fdddaf9dbb13da2fe7af0f429733166865ebcdda9840189fc65dc677b7181b34f1c0dc697905aa3af4f SHA512 4952f1cd293f1a4bf1721222579273c95f59adfa9385963617924f5f28232e1940ec045e18aeae83ad138176e4d887e952fe875b960279f3e0b7d982a790a4dc
DIST ipywidgets-7.7.0.tar.gz 4074763 BLAKE2B cff338dd635c57943161c78708e6a69abccaa46878e0bedb11ead76590b858ba57ce4dcfa8052533a4849da0dc9d5472987a7918fd2043462a21a908105d7910 SHA512 038da040912e6701762fb66fb3b6996ce0a59706afb05405b5932c02d34733842b227426f0b29eea115196bab384617425b0553c5db13a9dc832bddef63dfb92
diff --git a/dev-python/ipywidgets/files/ipywidgets-7.6.3-py310.patch b/dev-python/ipywidgets/files/ipywidgets-7.6.3-py310.patch
deleted file mode 100644
index f3d82d0a8ec1..000000000000
--- a/dev-python/ipywidgets/files/ipywidgets-7.6.3-py310.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From f9a13dbb3b8f1ffefef483bdb4c14f04f7743ff1 Mon Sep 17 00:00:00 2001
-From: Jason Grout <jgrout6@bloomberg.net>
-Date: Tue, 31 Dec 2019 12:57:52 -0800
-Subject: [PATCH] Fix more python 3 deprecations
-
----
- ipywidgets/widgets/interaction.py | 2 +-
- ipywidgets/widgets/tests/test_interaction.py | 3 ++-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/ipywidgets/widgets/interaction.py b/ipywidgets/widgets/interaction.py
-index 3dd7272047..6e3b9fc955 100644
---- a/ipywidgets/widgets/interaction.py
-+++ b/ipywidgets/widgets/interaction.py
-@@ -246,7 +246,7 @@ def update(self, *args):
- except Exception as e:
- ip = get_ipython()
- if ip is None:
-- self.log.warn("Exception in interact callback: %s", e, exc_info=True)
-+ self.log.warning("Exception in interact callback: %s", e, exc_info=True)
- else:
- ip.showtraceback()
- finally:
-diff --git a/ipywidgets/widgets/tests/test_interaction.py b/ipywidgets/widgets/tests/test_interaction.py
-index 1ee946744e..c792c5377a 100644
---- a/ipywidgets/widgets/tests/test_interaction.py
-+++ b/ipywidgets/widgets/tests/test_interaction.py
-@@ -249,7 +249,8 @@ def test_iterable_tuple():
- check_widgets(c, lis=d)
-
- def test_mapping():
-- from collections import Mapping, OrderedDict
-+ from collections.abc import Mapping
-+ from collections import OrderedDict
- class TestMapping(Mapping):
- def __init__(self, values):
- self.values = values
diff --git a/dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild b/dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild
deleted file mode 100644
index a3cebfe5cd69..000000000000
--- a/dev-python/ipywidgets/ipywidgets-7.6.5-r2.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="IPython HTML widgets for Jupyter"
-HOMEPAGE="https://ipywidgets.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/ipykernel-4.5.1[${PYTHON_USEDEP}]
- >=dev-python/ipython_genutils-0.2.0[${PYTHON_USEDEP}]
- >=dev-python/nbformat-4.2.0[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/widgetsnbextension-3.5.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}/${PN}-7.6.3-py310.patch"
-)
-
-src_prepare() {
- # upstream hack to autoconfigure ipywidgets in jupyter
- # we don't have jupyterlab_widgets packaged
- sed -i -e '/jupyterlab_widgets/d' setup.py || die
- distutils-r1_src_prepare
-}