summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-12 17:28:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-12 18:29:42 +0200
commitc17160dbaf49804af56939fce9b64e90afba748a (patch)
tree65a4b19163560ea3fb554292fdd11a5c85a1090b /dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
parentdev-python/jaraco-env: Enable py3.13 (diff)
downloadgentoo-c17160dbaf49804af56939fce9b64e90afba748a.tar.gz
gentoo-c17160dbaf49804af56939fce9b64e90afba748a.tar.bz2
gentoo-c17160dbaf49804af56939fce9b64e90afba748a.zip
dev-python/jaraco-test: Fix testing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-test/jaraco-test-5.4.0.ebuild')
-rw-r--r--dev-python/jaraco-test/jaraco-test-5.4.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
index 185131c7284f..8c6366b403af 100644
--- a/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
+++ b/dev-python/jaraco-test/jaraco-test-5.4.0.ebuild
@@ -28,6 +28,13 @@ RDEPEND="
distutils_enable_tests pytest
+src_test() {
+ # workaround namespaces blocking test.support import (sigh!)
+ mv jaraco/test jaraco_test || die
+ rmdir jaraco || die
+ distutils-r1_src_test
+}
+
python_test() {
# while technically these tests are skipped when Internet is
# not available (they test whether auto-skipping works), we don't