summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 23:25:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 23:25:36 +0200
commit3ee2c4941febad134f139f5a5aa461b2cd182fee (patch)
treea828ded850da1159555d1ba54a48eaf890fa3dbe /dev-python/joblib
parentdev-python/Faker: Bump to 9.2.0 (diff)
downloadgentoo-3ee2c4941febad134f139f5a5aa461b2cd182fee.tar.gz
gentoo-3ee2c4941febad134f139f5a5aa461b2cd182fee.tar.bz2
gentoo-3ee2c4941febad134f139f5a5aa461b2cd182fee.zip
dev-python/joblib: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/joblib')
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index a8a91d769717..6686dc714c79 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1 +1,2 @@
DIST joblib-1.0.1.tar.gz 347176 BLAKE2B 046ec87d446eb3075d867e41bb87039062531294d9b6c0be8d3cb42ccdf47dd58f1bc46a599ade64fc210e93fcad6e3007af82dbc670e1eaec1c67b425f87712 SHA512 39b1579efad44d6e51db501dbaa8378e7c8a423822ee3264a8bed44b720f59e6d08993a00f995c45beada3dd59b8e4101c47e587c9bf72027b01723838b533ab
+DIST joblib-1.1.0.tar.gz 350428 BLAKE2B 6b9b449e012752e561b267c8e27475252fee8d56406430bc570abc6da22b913bb09b7ad8708c29c7d7c338e4f541144b4514976a9f4ce017c3764b4d717eaba8 SHA512 5efcf9fc6dd4e2cf30599dc50373e40580be38fa15c2295519eb8c3b94a07b0fe2d1a9960ec4a67846aa3176335a2634b21107664032966166b973dcbded0cea
diff --git a/dev-python/joblib/joblib-1.1.0.ebuild b/dev-python/joblib/joblib-1.1.0.ebuild
new file mode 100644
index 000000000000..4f96b96a5b16
--- /dev/null
+++ b/dev-python/joblib/joblib-1.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ # https://github.com/joblib/joblib/issues/1115
+ sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
+ -i joblib/test/test_memory.py || die
+
+ distutils-r1_python_prepare_all
+}